APM 7.5.0 not resolving API paths in Transactions

Kibana version: 7.5.0

Elasticsearch version: 7.5.0

APM Server version: 7.5.0

APM Agent language and version: Python - 5.3.2

Deployment method: docker-compose

I am seeing a situation where individual api endpoints are not treated as separate transactions. I have seen this work correctly in prior APM versions.

Hi @James_Leatherman

First of all, welcome to our forums!

The transaction name, which we use to distinguish endpoints, is determined on the agent, so it shouldn't be affected by upgrading the stack to 7.5. Did you upgrade the agent at the same time, or do any other changes within your app or with agent settings? Also, can you tell me which framework you use (Django, Flask, Django Rest Framework, ...)

What confuses me a bit is that you only see transactions with 4xx status code (so e.g. 401, 403, 404 status). Is that to be expected or is there some other problem there?

Hi - yes, sorry. I did upgrade the Python agent as well. Here are the details:

I am using your Pyramid library from https://github.com/beniwohli/pyramid-elasticapm-demo/blob/master/app/elasticapm_integration.py.

I have iterated through many of the recent agent versions since 5.x. I don't offhand remember which one I started with, but it worked: https://pypi.org/project/elastic-apm/#history (Edit: I started with 5.1.2)

The 400s are due to some bad authentication - that doesn't really factor in here.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.