APM Index Pattern Numeric

I follow all instructions to install APM Server on my server that had java application, and works everthing fine, but the elastic has INFO about the ( illegal_argument_exception: index name [apm-7.0.0-span-2019.05.03] does not match pattern '^.*-\d+$' ).

Why the apm-server dont create the index with pattern like this apm-7.0.0-span-2019.05.03-001, so anyone knows about this.


Hi Jader,

You can see the default indices for apm-server 7.0.0 here:
as you can see they don't end in -\d+.
You can modify the indices yourself uncommenting those lines in the configuration and changing them as you want.
You might find this bit of documentation useful: https://www.elastic.co/guide/en/apm/server/current/elasticsearch-output.html#indices-option-es

Let me know if that helps,


Hey i have seen the documentation but don't have nothing about to set to the end of the format to generate the sequence Ex. apm-%{[version]}-span-%{+yyyy.MM.dd}-0001 another day apm-%{[version]}-span-%{+yyyy.MM.dd}-0002 and in the git dont have nothing too.



Just to understand the issue better, what are you trying to achieve by adding that sequence suffix?



Tell me how i can to fix it.


That is useful info, thanks. My question now is if you created an index rollover alias, and how.

Can you run this query for me from the Kibana Dev Tools Console?

GET apm-*/_settings

Grab the index.lifecycle.rollover_alias from the response, and then would you let me know what this says:


If you had not created it, you can do it like so:

PUT apm-7.0.0-span-001 
  "aliases": {
      "is_write_index": true

Let me know if that helps


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.