APM Index Pattern is created automatically in Kibana

Kibana version: 7.14.2

Elasticsearch version: 7.14.2

APM Server version: 7.14.2

APM Agent language and version: NodeJS ^3.17.0

Browser version: Microsoft Edge 95.0.1020.40

Original install method (e.g. download page, yum, deb, from source, etc.) and version: Kubernetes with official Docker image docker.elastic.co/apm/apm-server:7.14.2

Fresh install or upgraded from other version? Upgraded from 7.9.2

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

APM Server --> Apache Kafka --> Logstash --> Elasticsearch

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

Hi, everyone

I have configured Kibana with the follow configuration:

apm_oss.indexPattern: "apm-*"
apm_oss.errorIndices: "apm-*"
apm_oss.onboardingIndices: "apm-*"
apm_oss.spanIndices: "apm-*"
apm_oss.transactionIndices: "apm-*"
apm_oss.metricsIndices: "apm-*"
apm_oss.sourcemapIndices: "apm-*"

However, there is an index_pattern created which is called traces-apm*,logs-apm*,metrics-apm*,apm-*. If I remove this index_pattern, it is created again when I enter in APM section.

Is it normal this kind of behaviour ?

Thanks in advance,



Hi there,

Yes, this is the expected behaviour. If you don't want this you can disable it with this config:

xpack.apm.autocreateApmIndexPattern: false

Furthermore, I've created an issue to set a human-readable title for the index pattern. If the index pattern was called "APM UI" would that improve the experience?



Thank very much :smiley:. Should this setting be added to APM settings in Kibana doc?

Regarding your question, I would rather apm-ui. However, in my opinion, it would be nice to configure all these features in kibana.yml in order to get a GitOps culture.

Regards :vulcan_salute:

Should this setting be added to APM settings in Kibana doc?

Good idea, it probably should! Would you mind opening an issue to propose this?


1 Like


I just created the issue #117618.



This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.