APM server doesn't start


I install apm server on my local machine and i configure the output to elastic cloud instance. I also enabled rum agent. When i try to start the apm service i am getting an error that windows couldn't start the service on local computer and in logs i get nothing. I also run apm-server.exe test config and test output and both of them are OK.
Does anyone have an idea of what i am doing wrong?


Kibana version: 6.5.4

Elasticsearch version:6.5.4

APM Server version:6.5.4

APM Agent language and version:RUM js

Browser version:

Original install method (e.g. download page, yum, deb, from source, etc.) and version: https://www.elastic.co/guide/en/apm/server/6.4/installing-on-windows.html

Fresh install or upgraded from other version? fresh install

I have the following yml file:

  # Defines the host and port the server is listening on.  use "unix:/path/to.sock" to listen on a unix domain socket.
  host: apm url
  secret_token: ****

    enabled: true
    allow_origins : ['*']
    # Registers pipeline definitions in Elasticsearch on APM Server startup. Defaults to false.
    enabled: true
    # Overwrites existing pipeline definitions in Elasticsearch. Defaults to true.
    overwrite: false

#================================ General ======================================

#============================== Template =====================================
# Set to false to disable template loading.
setup.template.enabled: true
setup.template.name: "apm-%{[beat.version]}"
setup.template.pattern: "apm-%{[beat.version]}-*"
#============================== Deprecated: Dashboards =====================================

#============================== Deprecated: Kibana =====================================

#============================= Elastic Cloud ==================================

# These settings simplify using APM Server with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# [deprecated] `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
cloud.id: ******

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
cloud.auth: ******

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
  hosts: ["http://localhost:9200"]
  enabled: true
  protocol: "http"
  username: "elastic"
  password: "changeme"
  worker: 1
  index: "apm-%{[beat.version]}-%{+yyyy.MM.dd}"
    - index: "apm-%{[beat.version]}-sourcemap"
        processor.event: "sourcemap"

    - index: "apm-%{[beat.version]}-error-%{+yyyy.MM.dd}"
        processor.event: "error"

    - index: "apm-%{[beat.version]}-transaction-%{+yyyy.MM.dd}"
        processor.event: "transaction"

    - index: "apm-%{[beat.version]}-span-%{+yyyy.MM.dd}"
        processor.event: "span"

    - index: "apm-%{[beat.version]}-metric-%{+yyyy.MM.dd}"
        processor.event: "metric"

    - index: "apm-%{[beat.version]}-onboarding-%{+yyyy.MM.dd}"
        processor.event: "onboarding"
  - pipeline: "apm_user_agent"

You could set the log level to debug and check if this helps with getting more helpful information from the logs.

You mentioned you are testing a local setup. While your apm-server.yml file doesn't show the configured host I assume you are using apm-server.host: localhost:8200?

I see you have changed some config options. Would you mind trying to start the server with the default config yml file to narrow down if some of the config changes are causing the issue?


I am trying to use apm server on elastic cloud enterprise but i don't know exactly how i should configure or what. I know how to configure rum agent but i have also to configure amp-server.yml file, right?


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.