APM Server logs not being generated

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

Kibana version: NA

Elasticsearch version: NA

APM Server version: 7.1.2

APM Agent language and version: Java

Browser version: NA

Original install method (e.g. download page, yum, deb, from source, etc.) and version:

==========Following configuration -=======================

#================================ Logging ======================================
# There are three options for the log output: syslog, file, stderr.
# Under Windows systems, the log files are per default sent to the file output,
# under all other system per default to syslog.

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
logging.level: debug

# Enable debug output for selected components. To enable all selectors use ["*"]
# Other available selectors are "beat", "publish", "service"
# Multiple selectors can be chained.
#logging.selectors: [ colortokens ]

# Send all logging output to syslog. The default is false.
#logging.to_syslog: true

# If enabled, apm-server periodically logs its internal metrics that have changed
# in the last period. For each metric that changed, the delta from the value at
# the beginning of the period is logged. Also, the total values for
# all non-zero internal metrics are logged on shutdown. The default is true.
logging.metrics.enabled: false

# The period after which to log the internal metrics. The default is 30s.
#logging.metrics.period: 30s

# Logging to rotating files. Set logging.to_files to false to disable logging to
# files.
logging.to_files: true
  # Configure the path where the logs are written. The default is the logs directory
  # under the home path (the binary location).
  path: /var/log/apm-server

  # The name of the files where the logs are written to.
  name: apm-server

  # Configure log file size limit. If limit is reached, log file will be
  # automatically rotated
  rotateeverybytes: 10485760 # = 10MB

  # Number of rotated log files to keep. Oldest files will be deleted first.
  keepfiles: 7

  # The permissions mask to apply when rotating log files. The default value is 0600.
  # Must be a valid Unix-style file permissions mask expressed in octal notation.
  permissions: 0600

  # Enable log file rotation on time intervals in addition to size-based rotation.
  # Intervals must be at least 1s. Values of 1m, 1h, 24h, 7*24h, 30*24h, and 365*24h
  # are boundary-aligned with minutes, hours, days, weeks, months, and years as
  # reported by the local system clock. All other intervals are calculated from the
  # Unix epoch. Defaults to disabled.
  #interval: 0

# Set to true to log messages in json format.
#logging.json: false

I dont see anything in /var/log/

Fresh install or upgraded from other version?

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

Description of the problem including expected versus actual behaviour. Please include screenshots (if relevant):

Steps to reproduce:

  1. enabled logging in the apm-server.yml file with above configuration.

Errors in browser console (if relevant):

Provide logs and/or server output (if relevant):

Is apm-server running under systemd? If so, the logs are in the systemd jourrnal viewable with journalctl -u apm-server.

Is this related to your other discuss post or a separate issue?

No.. I'm running with ./apm-server

Can anyone share on this ?

Have you checked that apm-server has proper permissions to write to the configured path in /var/log?

yes. i have checked it

Have you ensured to start apm-server with ./apm-server without providing the -e flag?

./apm-server -e -d "*" -c apm-server.yml using this command.

Thank it solved the problem. can it log to console also . Im trying on kubernetes.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.