Apm-server monitoring through metricbeat


as explained in the latest APM server documentation, it is possible to monitor the APM server through metricbeat.
The only thing which needs to be done is to add this to the apm-server.yml:
http.enabled: true http.port: 5069

I defined 5069 as my port, but restarting the apm server, the port is not open.
Doing that in a beats setup and restarting the beat, the port is opened, as checked with "netstat -anp | grep "LISTEN "".
Any idea how to achieve this?

Thank you very much.

Hi @Christoph_Quadt,
I just tried it out with the 7.10 branch and the port was enabled as expected. Therefore it sounds to me like the config file or the config options might not be picked up as expected. Have you customized any other settings and do you see them being applied? You could try to directly pass in the options when starting the APM Server (e.g. ./apm-server -E http.enabled=true -E http.port=5069). If that works, then have a look at your config file again.
If that also doesn't work please share which APM Server version you are using and how you have deployed it (tar, docker, ..).

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.