APM server not connecting to ElasticSearch

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

Kibana version:

Elasticsearch version:

APM Server version:

APM Agent language and version:
none yet

Browser version:
Chrome 72.0.3626.109

Original install method (e.g. download page, yum, deb, from source, etc.) and version:
Zip from dowload page

Fresh install or upgraded from other version?
Fresh install

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.
Running on Windows 10, don't think it's supported but have seen people running it and ElasticSearch and Kibana seem to be working fine

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):
After following all the steps to install APM server, when I go to APM in Kibana I see this:

"There's no APM index pattern with the title "apm-*" available. To use the Query bar, please choose to import the APM index pattern via the Setup Instructions."

When I go to the Setup Instructions, I can see I've done everything mentioned, but when I click Check APM Server Status I get "APM Server has still not connected to Elasticsearch".

When I run apm-server test output command, I get the following output, which seems fine:
elasticsearch: http://localhost:9200...
parse url... OK
parse host... OK
dns lookup... OK
addresses:, ::1
dial up... OK
TLS... WARN secure connection disabled
talk to server... OK
version: 6.6.0

I guess my assumption that things would work downloading whatever version is on the download page for each component was wrong. I downloaded APM 6.6.0, matching the versions I had for ElasticSearch and Kibana and now I get "You have correctly setup APM Server". So looks like I'm all good there.

Hi Thomas,
as you mentioned Kibana 6.6 is not compatible to show APM data ingested with APM Server 7.0.0-beta1.
Glad to hear everything works now.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.