Apm server secret_token

Hi Team,

i would like to change secret_token of apm server config, i am using the following config, but the token is not getting reflected

  - secretName: test-apm-token
       enabled: true
      secret_token: "${SECRET_TOKEN}"

PS: I am creating a secret before hand
kubectl create secret generic apm-secret-token --from-literal=SECRET_TOKEN=


The APM token is stored in a dedicated Secret, you can find the relevant documentation here.

I'm wondering if this is not preventing your secure setting to be applied :thinking:

Could you try to update the dedicated secret directly ?

Hi Michael,

Thanks for your reply, i found out what the issue was:

  1. the secret name should be created before i create apm custom resource with the specific format i.e. ${cluster-name}-apm-token
  2. the key in the secret should be lower case as secret-token , if the above criteria is not met operator will delete the secret and create a new one.

so i made identical secret which operator doesn't delete and create a new one automatically.