App Search error create engine

The documentation describes the process of creating a new Engine through the API but with the default type.

How to create a Engine with elasticsearch type?

I look at debugging requests that come from Kibana, repeat the same request from the API - I get a 400 bad request response.

POST "/api/as/v0/engines"
{"name"=>"ix-name", "search_index"=>{"type"=>"elasticsearch", "index_name"=>"ix_name", "alias_name"=>"search-ix-name-alias"}}
POST "/api/as/v1/engines"
{"name"=>"ix-name", "search_index"=>{"type"=>"elasticsearch", "index_name"=>"ix_name", "alias_name"=>"search-ix-name-alias"}}

Hi @GHostlyFOX , welcome back!

The following should work:

POST "/api/as/v0/engines"

    "name": "engine-name",
    "type": "elasticsearch",
    "index_name": "search-existing-es-index-name"

Where "index_name" must be an existing Search Index name. It must start with search- to make sure Enterprise Search is able to manage it.

Please keep in mind that this API is in Beta, and is subject to change in the future.

I solved the problem.
The error was due to the restriction of user roles.
The user created inside the module does not have rights to add such a Engine.
And API keys too.

Only assigning roles enterprise-search-workplace-search-admin and enterprise-search-app-search-owner made it possible to add Engine type = elasticsearch.

At the same time, the procedure for adding this type of sources is not described anywhere in the documentation.

I'm glad you solved the problem, @GHostlyFOX !

This is not documented yet, as this is a beta feature that is undergoing changes at this very moment. We have lots of plans for Elasticsearch based Engines. Stay tuned!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.