Arabic hunspell doesn't work


(Netanel Malka) #1

I tried to load the arabic hunspell from the elastic hunspell project .
I followed the official elastic doc
and I succeeded with the others dictionaries, except Arabic.
I got this exception:

{
  "error": {
    "root_cause": [
      {
        "type": "index_creation_exception",
        "reason": "failed to create index"
      }
    ],
    "type": "unchecked_execution_exception",
    "reason": "ElasticsearchException[Could not find hunspell dictionary [ar_ooe]]",
    "caused_by": {
      "type": "exception",
      "reason": "Could not find hunspell dictionary [ar_ooe]"
    }
  },
  "status": 500
}

I tried with all the arabic versions: ar-moz, ar-ooe, ar-ooe2
I tried it in elastic 2.4.1 and elastic 5.0.2
Thanks,


(David Pilato) #2

What do you have in your elasticsearch config dir? Can you share the result of a ls -l config/hunspell?

Did you read https://www.elastic.co/guide/en/elasticsearch/reference/5.1/analysis-hunspell-tokenfilter.html?

What exactly steps did you follow?


(Netanel Malka) #3

I installed elastic with rpm, so I have the hunspell dir in:
/etc/elasticsearch/
The folder have the right privileges. The other hunspell dictionaries work fine and they have the same privileges.

I followed this guide and I also checked it and it's working for the other dictionaries(en_US, cy_GB etc.)
There is some logs that i can see except this error?..
Thanks


(David Pilato) #4

Can you share the result of a ls -l config/hunspell?


(Netanel Malka) #5

ls -l output:
drwxr-xr-x. 2 root root 4096 Nov 16 15:54 ar-moz drwxr-xr-x. 2 root root 4096 Nov 16 15:54 ar-ooe drwxr-xr-x. 2 root root 4096 Nov 16 15:54 ar-ooe-2 drwxr-xr-x. 2 root root 4096 Nov 16 15:54 en_US


(David Pilato) #6

Thanks.

Can you ls now the content of all subdirs?


(Netanel Malka) #7

ls -l output for ar:
drwxrwxrwx. 1 root root 406229 Nov 16 15:54 ar.aff drwxrwxrwx. 1 root root 2218665 Nov 16 15:54 ar.dic drwxrwxrwx. 1 root root 420 Nov 16 15:54 README-en drwxrwxrwx. 1 root root 50 Nov 16 15:54 settings.yml

I don't have network connection in my office so it takes me a lot of time to write it..
I see this output for all the hunspell dic folders


(Netanel Malka) #8

Could someone help me with that?..
Thanks.


(David Pilato) #9

In the trace you pasted I can see ar_ooe but you installed ar-ooe. Can it be your issue?


(Netanel Malka) #10

Unfortunately not. it's a typo when i copied it manually.


(David Pilato) #11

Just to make sure. Are you running elasticsearch as root user?
I don't understand why your files belongs to root user here.

May be try to change that?

I have no more idea (I never used that TBH). May be @Clinton_Gormley1 has more ideas?


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.