Are ELK stack components from the Downloads link compatible with each other?


(Brian Yoder) #1

Are versions of the ELK stack components compatible with each other as seen
by the Elasticsearch Downloads link? Or do I need to specifically regress
back to the older 1.1.1 ES version?

From the following Downloads site
http://www.elasticsearch.org/overview/elkdownloads/ I downloaded the most
recent versions of each of the ELK stack components. As Elasticsearch had
been updated (the download site pointed to ES 1.2), I upgraded my local ES
instance and then updated my Java server code for my other application. And
I am trying to share the same ES version with my application and with ELK
(keeping ES up to date is easier if I only need to focus on one version!).

Then I looked inside logstash and I see it's still assuming ES 1.1.1 and
the versions of Lucene are very different between the ES 1.2 version and
logstash 1.4.1 version:

$ unzip -v logstash-1.4.1.zip | grep lucene

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-analyzers-common-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-codecs-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-core-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-grouping-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-highlighter-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-join-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-memory-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-misc-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-queries-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-queryparser-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-sandbox-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-spatial-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-suggest-4.7.2.jar
logstash-1.4.1/vendor/kibana/app/panels/query/editors/lucene.html
logstash-1.4.1/vendor/kibana/app/panels/query/help/lucene.html

$ unzip -v elasticsearch-1.2.0.zip | grep lucene
elasticsearch-1.2.0/lib/lucene-codecs-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-core-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-analyzers-common-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-queries-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-memory-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-highlighter-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-queryparser-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-sandbox-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-suggest-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-misc-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-join-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-grouping-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-spatial-4.8.1.jar

I only ask based on my reading of this newsgroup all about the many version
issues with plug-ins. Up until now, I have never used a plug-in or a river,
and instead keep my own Java code up-to-date and tested with each new
release of ES. That way, I stomp version issues out of existence very early.

Brian

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d5cd0887-cf66-431a-94b5-403cbc0a1491%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

With LS in particular, you are better off using the HTTP output to ES so
you are not locked into version compatibility requirements.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 29 May 2014 05:06, InquiringMind brian.from.fl@gmail.com wrote:

Are versions of the ELK stack components compatible with each other as
seen by the Elasticsearch Downloads link? Or do I need to specifically
regress back to the older 1.1.1 ES version?

From the following Downloads site
http://www.elasticsearch.org/overview/elkdownloads/ I downloaded the most
recent versions of each of the ELK stack components. As Elasticsearch had
been updated (the download site pointed to ES 1.2), I upgraded my local ES
instance and then updated my Java server code for my other application. And
I am trying to share the same ES version with my application and with ELK
(keeping ES up to date is easier if I only need to focus on one version!).

Then I looked inside logstash and I see it's still assuming ES 1.1.1 and
the versions of Lucene are very different between the ES 1.2 version and
logstash 1.4.1 version:

$ unzip -v logstash-1.4.1.zip | grep lucene

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-analyzers-common-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-codecs-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-core-4.7.2
.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-grouping-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-highlighter-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-join-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-memory-4.7.2.jar
logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-misc-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-queries-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-queryparser-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-sandbox-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-spatial-4.7.2.jar

logstash-1.4.1/vendor/jar/elasticsearch-1.1.1/lib/lucene-suggest-4.7.2.jar
logstash-1.4.1/vendor/kibana/app/panels/query/editors/lucene.html
logstash-1.4.1/vendor/kibana/app/panels/query/help/lucene.html

$ unzip -v elasticsearch-1.2.0.zip | grep lucene
elasticsearch-1.2.0/lib/lucene-codecs-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-core-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-analyzers-common-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-queries-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-memory-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-highlighter-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-queryparser-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-sandbox-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-suggest-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-misc-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-join-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-grouping-4.8.1.jar
elasticsearch-1.2.0/lib/lucene-spatial-4.8.1.jar

I only ask based on my reading of this newsgroup all about the many
version issues with plug-ins. Up until now, I have never used a plug-in or
a river, and instead keep my own Java code up-to-date and tested with each
new release of ES. That way, I stomp version issues out of existence very
early.

Brian

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d5cd0887-cf66-431a-94b5-403cbc0a1491%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d5cd0887-cf66-431a-94b5-403cbc0a1491%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624YZ-F4gfUt8wBz_ZLciiE4kSF-sZWE7UE7kUig%2BfO9oAg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3