Attempted to resurrect connection to dead ES instance

Am I missing something? I am trying to send in a basic tryout some logs from a Server with Filebeat, via Logstash to Elasticsearch. I am getting the data from Beats in Logstash. But Logstash is giving me following message constantly:

[2022-03-23T16:20:12,663][WARN ][logstash.outputs.elasticsearch][main] Attempted to resurrect connection to dead ES instance, but got an error {:url=>"https://localhost:9200/", :exception=>LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError, :message=>"Got response code '401' contacting Elasticsearch at URL 'https://localhost:9200/'"}

I tried a basic pipeline, to see if the connection works. Like in this documentation https://www.elastic.co/guide/en/logstash/current/ls-security.html

# The # character at the beginning of a line indicates a comment. Use
# comments to describe your configuration.
input {
	beats {
        	port => "5044"
    	}
}
# The filter part of this file is commented out to indicate that it is
# optional.
# filter {
#
# }
output {
    elasticsearch {
        hosts => [ "https://localhost:9200" ]
	ssl => true
	cacert => "C:\\Users\\Name\\ElasticStack\\logstash-8.0.1\\config\\certs\\http_ca.crt"
    }
}

Any ideas how to solve this, to get the connection? Elasticsearch is running.

Security features ( authentication and TLS ) are enabled by default in Elasticsearch, as of 8.0.0. See Secure your connection to Elasticsearch | Logstash Reference [8.1] | Elastic to configure the Elasticsearch output to authenticate to Elasticsearch. Hope this helps!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.