Auto interval date histogram illegal argument exception, buckets must be less than 333

I tried to create an auto_date_histogram to generate some graphs in our application and I would like to keep the length of this graph as 360 points (buckets).
I'm trying to achieve at least for the last 6h a graph per minute, but if we increase the time range, I get buckets by hours, days, and so on.

However, when I try to use 360 buckets I get this error

  "error" : {
    "root_cause" : [
        "type" : "illegal_argument_exception",
        "reason" : "buckets must be less than 333"

There is a way to increase this limit?

Hello, I guess this might help you:
Go to Management > Advanced Settings, then find Maximum buckets and Target buckets and increase the maximum.
One another probably solution is to increase search.max_buckets with api:

PUT _cluster/settings
"transient": {
"search.max_buckets": 10000

I'm not sure with them, I hope it can help you.

Thanks for your help Mohammad, but it didn't work.
I'm not confident that is related to max_buckets.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.