Autocomplete mapping error


(Joshua Corb) #1

We are running into an issue where we are getting mapping issues. We are
have tried on both Ubuntu and OSX. We are using java 1.7. Attached is our
node configuration, and below is the error we are getting.

11:12:47,856 WARN [org.elasticsearch.indices.cluster]
(elasticsearch[Nemesis][clusterService#updateTask][T#1]) [Nemesis] [need]
failed to add mapping [need], source
[{"need":{"properties":{"defaultTextValue":{"type":"string"},"description":{"type":"string"},"endDate":{"type":"string"},"id":{"type":"string"},"imageURL":{"type":"string"},"location":{"type":"geo_point"},"mainCategory":{"type":"string","store":true,"index_analyzer":"keyword"},"postDate":{"type":"string"},"subCategory":{"type":"string","store":true,"index_analyzer":"keyword"},"tags":{"type":"string","store":true,"index_analyzer":"keyword"},"title":{"type":"multi_field","fields":{"title":{"type":"string"},"title.autocomplete":{"type":"string","store":true,"index_analyzer":"autocomplete","search_analyzer":"autocomplete_search","include_in_all":false},"title.untouched":{"type":"string","index":"not_analyzed","omit_norms":true,"index_options":"docs","include_in_all":false}}},"user":{"type":"string","store":true,"index_analyzer":"keyword"},"version":{"type":"long"}}}}]:
org.elasticsearch.index.mapper.MapperParsingException: Analyzer
[autocomplete] not found for field [title.autocomplete]
at
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:130)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:176)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:314)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:193)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:417)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:381)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:179)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:414)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
[elasticsearch-0.90.7.jar:]
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
[rt.jar:1.7.0_45]
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
[rt.jar:1.7.0_45]
at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3c8b1aaa-96e7-43a0-a148-38d92c79bbef%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Sang Dang) #2

Maybe your custom autocomplete isn't work.
I see that:
index.analysis.analyzer.autocomplete:
type: custom
tokenizer: whitespace
filter: lowercase#, auto_edge_ngram
Maybe you should remove # and restart your es server.
After that please check your log whether ES start right.

On Wednesday, December 18, 2013 11:09:41 AM UTC-8, Joshua Corb wrote:

We are running into an issue where we are getting mapping issues. We are
have tried on both Ubuntu and OSX. We are using java 1.7. Attached is our
node configuration, and below is the error we are getting.

11:12:47,856 WARN [org.elasticsearch.indices.cluster]
(elasticsearch[Nemesis][clusterService#updateTask][T#1]) [Nemesis] [need]
failed to add mapping [need], source
[{"need":{"properties":{"defaultTextValue":{"type":"string"},"description":{"type":"string"},"endDate":{"type":"string"},"id":{"type":"string"},"imageURL":{"type":"string"},"location":{"type":"geo_point"},"mainCategory":{"type":"string","store":true,"index_analyzer":"keyword"},"postDate":{"type":"string"},"subCategory":{"type":"string","store":true,"index_analyzer":"keyword"},"tags":{"type":"string","store":true,"index_analyzer":"keyword"},"title":{"type":"multi_field","fields":{"title":{"type":"string"},"title.autocomplete":{"type":"string","store":true,"index_analyzer":"autocomplete","search_analyzer":"autocomplete_search","include_in_all":false},"title.untouched":{"type":"string","index":"not_analyzed","omit_norms":true,"index_options":"docs","include_in_all":false}}},"user":{"type":"string","store":true,"index_analyzer":"keyword"},"version":{"type":"long"}}}}]:
org.elasticsearch.index.mapper.MapperParsingException: Analyzer
[autocomplete] not found for field [title.autocomplete]
at
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:130)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:176)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:314)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:193)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:417)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:381)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:179)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:414)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
[elasticsearch-0.90.7.jar:]
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
[rt.jar:1.7.0_45]
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
[rt.jar:1.7.0_45]
at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/86b7430c-574f-4110-b4ae-948ec1329c89%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Sang Dang) #3

You could also check your custom analyzer like that:

your_index: Index which use your custom analyzer.

http://your_server_ip:9200/your_index/_analyze?text=your_query_here

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d5a63a84-399e-4e4c-8872-4c07d75cc32e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Joshua Corb) #4

even with that change we are still running into the same issue. It seems
that elastic search isn't reading the config correctly, and never creates
the index correctly.

On Wed, Dec 18, 2013 at 8:18 PM, kidkid zkidkid@gmail.com wrote:

You could also check your custom analyzer like that:

your_index: Index which use your custom analyzer.

http://your_server_ip:9200/your_index/_analyze?text=your_query_here

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/8oB1lM8sUHg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d5a63a84-399e-4e4c-8872-4c07d75cc32e%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAG%2BZfhAHC51DYTCROgCa6zeQd2hDJCcNGuGdxKQM2FgUwX0D9w%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Sang Dang) #5

I think you should check step by step:

  1. Your custom analyzer is fine.
  2. Your index have been using your custom analyzer fines.

And if you still get problem, please give more info so other could try to
reproduce it and help you.

On Wednesday, December 18, 2013 8:58:55 PM UTC-8, Joshua Corb wrote:

even with that change we are still running into the same issue. It seems
that elastic search isn't reading the config correctly, and never creates
the index correctly.

On Wed, Dec 18, 2013 at 8:18 PM, kidkid <zki...@gmail.com <javascript:>>wrote:

You could also check your custom analyzer like that:

your_index: Index which use your custom analyzer.

http://your_server_ip:9200/your_index/_analyze?text=your_query_here

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/8oB1lM8sUHg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d5a63a84-399e-4e4c-8872-4c07d75cc32e%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e93705c9-6d37-4f94-a798-34491f8cb29e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Joshua Corb) #6

The config is fine...What piece of information would you need?

On Wed, Dec 18, 2013 at 11:25 PM, kidkid zkidkid@gmail.com wrote:

I think you should check step by step:

  1. Your custom analyzer is fine.
  2. Your index have been using your custom analyzer fines.

And if you still get problem, please give more info so other could try to
reproduce it and help you.

On Wednesday, December 18, 2013 8:58:55 PM UTC-8, Joshua Corb wrote:

even with that change we are still running into the same issue. It seems
that elastic search isn't reading the config correctly, and never creates
the index correctly.

On Wed, Dec 18, 2013 at 8:18 PM, kidkid zki...@gmail.com wrote:

You could also check your custom analyzer like that:

your_index: Index which use your custom analyzer.

http://your_server_ip:9200/your_index/_analyze?text=your_query_here

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/8oB1lM8sUHg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d5a63a84-399e-4e4c-8872-4c07d75cc32e%
40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/8oB1lM8sUHg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e93705c9-6d37-4f94-a798-34491f8cb29e%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAG%2BZfhC1wBTkn0Mdtx4qmsLiWsD3aHC3k0OqmeTDb5fGM%2BwKkw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Lee Hinman) #7

On Wednesday, December 18, 2013 12:09:41 PM UTC-7, Joshua Corb wrote:

We are running into an issue where we are getting mapping issues. We are
have tried on both Ubuntu and OSX. We are using java 1.7. Attached is our
node configuration, and below is the error we are getting.

11:12:47,856 WARN [org.elasticsearch.indices.cluster]
(elasticsearch[Nemesis][clusterService#updateTask][T#1]) [Nemesis] [need]
failed to add mapping [need], source
[{"need":{"properties":{"defaultTextValue":{"type":"string"},"description":{"type":"string"},"endDate":{"type":"string"},"id":{"type":"string"},"imageURL":{"type":"string"},"location":{"type":"geo_point"},"mainCategory":{"type":"string","store":true,"index_analyzer":"keyword"},"postDate":{"type":"string"},"subCategory":{"type":"string","store":true,"index_analyzer":"keyword"},"tags":{"type":"string","store":true,"index_analyzer":"keyword"},"title":{"type":"multi_field","fields":{"title":{"type":"string"},"title.autocomplete":{"type":"string","store":true,"index_analyzer":"autocomplete","search_analyzer":"autocomplete_search","include_in_all":false},"title.untouched":{"type":"string","index":"not_analyzed","omit_norms":true,"index_options":"docs","include_in_all":false}}},"user":{"type":"string","store":true,"index_analyzer":"keyword"},"version":{"type":"long"}}}}]:
org.elasticsearch.index.mapper.MapperParsingException: Analyzer
[autocomplete] not found for field [title.autocomplete]
at
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:130)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:176)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:314)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:193)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:417)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:381)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:179)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:414)
[elasticsearch-0.90.7.jar:]
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
[elasticsearch-0.90.7.jar:]
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
[rt.jar:1.7.0_45]
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
[rt.jar:1.7.0_45]
at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]

Hi Joshua,

You have an issue in your elasticsearch.yml file, instead of:

index.analysis.analyzer.autocomplete:
type: custom
tokenizer: whitespace
filter: lowercase

You need to put the filter into an array (because it's a list of filters to
be applied), so it would look like so:

index.analysis.analyzer.autocomplete:
type: custom
tokenizer: whitespace
filter: [lowercase]

Using your configuration and making this change to all the custom
analyzers, I was able to create an index and analyze text with the
"autocomplete" analyzer.

;; Lee Hinman

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3713dcf7-0954-4996-bace-129bcefc2633%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Joshua Corb) #8

I have a feeling the issue is the application has a embedded version of
elastic search. Is there a default path that elastic search will look for a
configuration? Or a java variable I can add that will force it to look in a
specific path?

On Thu, Dec 19, 2013 at 3:04 PM, Lee Hinman matthew.hinman@gmail.comwrote:

On Wednesday, December 18, 2013 12:09:41 PM UTC-7, Joshua Corb wrote:

We are running into an issue where we are getting mapping issues. We are
have tried on both Ubuntu and OSX. We are using java 1.7. Attached is our
node configuration, and below is the error we are getting.

11:12:47,856 WARN [org.elasticsearch.indices.cluster]
(elasticsearch[Nemesis][clusterService#updateTask][T#1]) [Nemesis]
[need] failed to add mapping [need], source [{"need":{"properties":{"
defaultTextValue":{"type":"string"},"description":{"type"
:"string"},"endDate":{"type":"string"},"id":{"type":"string"
},"imageURL":{"type":"string"},"location":{"type":"geo_
point"},"mainCategory":{"type":"string","store":true,"index_
analyzer":"keyword"},"postDate":{"type":"string"},"
subCategory":{"type":"string","store":true,"index_analyzer":
"keyword"},"tags":{"type":"string","store":true,"index_
analyzer":"keyword"},"title":{"type":"multi_field","fields":
{"title":{"type":"string"},"title.autocomplete":{"type":"
string","store":true,"index_analyzer":"autocomplete","search_analyzer":"
autocomplete_search","include_in_all":false},"title.
untouched":{"type":"string","index":"not_analyzed","omit_
norms":true,"index_options":"docs","include_in_all":false}}
},"user":{"type":"string","store":true,"index_analyzer":"
keyword"},"version":{"type":"long"}}}}]: org.elasticsearch.index.mapper.MapperParsingException:
Analyzer [autocomplete] not found for field [title.autocomplete]
at org.elasticsearch.index.mapper.core.TypeParsers.
parseField(TypeParsers.java:107) [elasticsearch-0.90.7.jar:]
at org.elasticsearch.index.mapper.core.StringFieldMapper$
TypeParser.parse(StringFieldMapper.java:150) [elasticsearch-0.90.7.jar:]
at org.elasticsearch.index.mapper.multifield.
MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:130)
[elasticsearch-0.90.7.jar:]
at org.elasticsearch.index.mapper.object.ObjectMapper$
TypeParser.parseProperties(ObjectMapper.java:263)
[elasticsearch-0.90.7.jar:]
at org.elasticsearch.index.mapper.object.ObjectMapper$
TypeParser.parse(ObjectMapper.java:219) [elasticsearch-0.90.7.jar:]
at org.elasticsearch.index.mapper.DocumentMapperParser.
parse(DocumentMapperParser.java:176) [elasticsearch-0.90.7.jar:]
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:314)
[elasticsearch-0.90.7.jar:]
at org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:193)
[elasticsearch-0.90.7.jar:]
at org.elasticsearch.indices.cluster.IndicesClusterStateService.
processMapping(IndicesClusterStateService.java:417)
[elasticsearch-0.90.7.jar:]
at org.elasticsearch.indices.cluster.IndicesClusterStateService.
applyMappings(IndicesClusterStateService.java:381)
[elasticsearch-0.90.7.jar:]
at org.elasticsearch.indices.cluster.IndicesClusterStateService.
clusterChanged(IndicesClusterStateService.java:179)
[elasticsearch-0.90.7.jar:]
at org.elasticsearch.cluster.service.InternalClusterService$
UpdateTask.run(InternalClusterService.java:414)
[elasticsearch-0.90.7.jar:]
at org.elasticsearch.common.util.concurrent.
PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(
PrioritizedEsThreadPoolExecutor.java:135) [elasticsearch-0.90.7.jar:]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
[rt.jar:1.7.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
[rt.jar:1.7.0_45]
at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]

Hi Joshua,

You have an issue in your elasticsearch.yml file, instead of:

index.analysis.analyzer.autocomplete:
type: custom
tokenizer: whitespace
filter: lowercase

You need to put the filter into an array (because it's a list of filters
to be applied), so it would look like so:

index.analysis.analyzer.autocomplete:
type: custom
tokenizer: whitespace
filter: [lowercase]

Using your configuration and making this change to all the custom
analyzers, I was able to create an index and analyze text with the
"autocomplete" analyzer.

;; Lee Hinman

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/8oB1lM8sUHg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3713dcf7-0954-4996-bace-129bcefc2633%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAG%2BZfhDPNHRaoFc%2BatT5BNRz7BSDbboeGW1h8zSYPpi_MrAFmQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Lee Hinman) #9

On Thursday, December 19, 2013 4:40:21 PM UTC-7, Joshua Corb wrote:

I have a feeling the issue is the application has a embedded version of
elastic search. Is there a default path that elastic search will look for a
configuration? Or a java variable I can add that will force it to look in a
specific path?

You can configure it with the -Des.path.conf jvm configuration variable.
You can also retrieve the currently configured settings with the following:

curl 'localhost:9200/_nodes/settings?pretty'

which will look something like this (this example includes how your
analyzers will look):

{
"ok" : true,
"cluster_name" : "vouchd-search",
"nodes" : {
"nKB19zwmSY-a56JGPWqj9Q" : {
"name" : "Midas",
"transport_address" : "inet[/10.175.76.85:9300]",
"hostname" : "Xanadu.local",
"version" : "0.90.7",
"http_address" : "inet[/10.175.76.85:9200]",
"settings" : {
"path.home" : "/Users/hinmanm/esi/elasticsearch-0.90.7",
"foreground" : "yes",
"index.analysis.analyzer.autocomplete.type" : "custom",
"index.analysis.analyzer.autocomplete.filter.0" : "lowercase",
"index.analysis.analyzer.autocomplete_search.tokenizer" : "whitespace",
"index.analysis.analyzer.autocomplete_search.type" : "custom",
"cluster.name" : "vouchd-search",
"index.analysis.analyzer.autocomplete_search.filter.0" : "lowercase",
"index.analysis.filter.auto_edge_ngram.max_gram" : "15",
"index.analysis.filter.auto_edge_ngram.min_gram" : "2",
"index.analysis.filter.auto_edge_ngram.type" : "edgeNGram",
"index.analysis.analyzer.autocomplete.tokenizer" : "whitespace",
"name" : "Midas",
"path.logs" : "/Users/hinmanm/esi/elasticsearch-0.90.7/logs"
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/104edaa2-3c93-4021-a6ae-8b616ec6a516%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Joshua Corb) #10

So it seems not to be on the server side but on the client side. It doesn't
seem to connect to a server, and brings some sort of local instance up.
Within the searchContext-elasticsearch.xml

<?xml version="1.0" encoding="UTF-8"?>

<elasticsearch:node-client id="client" cluster-name="search-cluster" >

<bean id="elasticsearchTemplate"

class="org.springframework.data.elasticsearch.core.ElasticsearchTemplate">

<bean id="generalElasticsearchTemplate"

class="com.vouchd.search.core.GeneralElasticsearchTemplate">

<elasticsearch:repositories base-package="com.vouchd.search.repository"
    repository-impl-postfix="Impl"

factory-class="com.vouchd.search.repository.ElasticsearchRepositoryFactoryBean"
/>

How can I make this section read from a specific file to load the mappings?
I've also tried passing the settings path through the jvm settings.

On Thu, Dec 19, 2013 at 4:46 PM, Lee Hinman matthew.hinman@gmail.comwrote:

On Thursday, December 19, 2013 4:40:21 PM UTC-7, Joshua Corb wrote:

I have a feeling the issue is the application has a embedded version of
elastic search. Is there a default path that elastic search will look for a
configuration? Or a java variable I can add that will force it to look in a
specific path?

You can configure it with the -Des.path.conf jvm configuration variable.
You can also retrieve the currently configured settings with the following:

curl 'localhost:9200/_nodes/settings?pretty'

which will look something like this (this example includes how your
analyzers will look):

{
"ok" : true,
"cluster_name" : "vouchd-search",
"nodes" : {
"nKB19zwmSY-a56JGPWqj9Q" : {
"name" : "Midas",
"transport_address" : "inet[/10.175.76.85:9300]",
"hostname" : "Xanadu.local",
"version" : "0.90.7",
"http_address" : "inet[/10.175.76.85:9200]",
"settings" : {
"path.home" : "/Users/hinmanm/esi/elasticsearch-0.90.7",
"foreground" : "yes",
"index.analysis.analyzer.autocomplete.type" : "custom",
"index.analysis.analyzer.autocomplete.filter.0" : "lowercase",
"index.analysis.analyzer.autocomplete_search.tokenizer" : "whitespace",
"index.analysis.analyzer.autocomplete_search.type" : "custom",
"cluster.name" : "vouchd-search",
"index.analysis.analyzer.autocomplete_search.filter.0" : "lowercase",
"index.analysis.filter.auto_edge_ngram.max_gram" : "15",
"index.analysis.filter.auto_edge_ngram.min_gram" : "2",
"index.analysis.filter.auto_edge_ngram.type" : "edgeNGram",
"index.analysis.analyzer.autocomplete.tokenizer" : "whitespace",
"name" : "Midas",
"path.logs" : "/Users/hinmanm/esi/elasticsearch-0.90.7/logs"
}
}
}
}

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/8oB1lM8sUHg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/104edaa2-3c93-4021-a6ae-8b616ec6a516%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAG%2BZfhDK1deN3ZQc7iGk9E4nYqFaDmKNc-7YGmhve8mBF7y-XQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #11