AutoComplete


(paul) #1

Hi I am trying out auto-complete below is my mapping

{
"settings":{
"analysis":{
"filter":{
"syns_filter":{
"synonyms_path":"synonyms/synonym_country.txt",
"type":"synonym",
"ignore_case":true
},
"my_edgeNgram":{
"type":"edgeNGram",
"min_gram":3,
"max_gram":10
}
},
"analyzer":{
"autocomplete":{
"type":"custom",
"tokenizer":"standard",
"filter":[
"standard",
"lowercase",
"syns_filter",
"stop",
"my_edgeNgram"
]
}
},
"mappings":{
"autotest":{
"properties":{
"name":{
"type":"string",
"analyzer":"autocomplete"
}
}
}
}
}
}
}

When i Type "Massachusett"

I get the list of colleges That has "Massachusetts" in there name like

"Massachusetts Bay Community College"
"Middlesex Community College - Massachusetts"
"Springfield College - Massachusetts"
"Massachusetts Institute of Technology"
"Massachusetts School of Barbering"

But i want the college names that start with "Massachusetts" to come on top
I even tried ngram but still same behavior

Regards
Paul

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a12674e4-ee39-4ce3-9ebc-af6f98263df4%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Amit Soni) #2

did you try n-gram or edge n-gram?

-Amit.

On Fri, Jan 17, 2014 at 5:15 AM, paul avinashpaul85@gmail.com wrote:

Hi I am trying out auto-complete below is my mapping

{
"settings":{
"analysis":{
"filter":{
"syns_filter":{
"synonyms_path":"synonyms/synonym_country.txt",
"type":"synonym",
"ignore_case":true
},
"my_edgeNgram":{
"type":"edgeNGram",
"min_gram":3,
"max_gram":10
}
},
"analyzer":{
"autocomplete":{
"type":"custom",
"tokenizer":"standard",
"filter":[
"standard",
"lowercase",
"syns_filter",
"stop",
"my_edgeNgram"
]
}
},
"mappings":{
"autotest":{
"properties":{
"name":{
"type":"string",
"analyzer":"autocomplete"
}
}
}
}
}
}
}

When i Type "Massachusett"

I get the list of colleges That has "Massachusetts" in there name like

"Massachusetts Bay Community College"
"Middlesex Community College - Massachusetts"
"Springfield College - Massachusetts"
"Massachusetts Institute of Technology"
"Massachusetts School of Barbering"

But i want the college names that start with "Massachusetts" to come on
top
I even tried ngram but still same behavior

Regards
Paul

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/a12674e4-ee39-4ce3-9ebc-af6f98263df4%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAAOGaQKLh2_bX-o2W%3D4n9h3AEOSGMgf4y00w5p-ZTOEUOtG-kg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(paul) #3

Tried both I also have synonymous in my mapping is that causing the problem
On 18 Jan 2014 00:11, "Amit Soni" amitsoni29@gmail.com wrote:

did you try n-gram or edge n-gram?

-Amit.

On Fri, Jan 17, 2014 at 5:15 AM, paul avinashpaul85@gmail.com wrote:

Hi I am trying out auto-complete below is my mapping

{
"settings":{
"analysis":{
"filter":{
"syns_filter":{
"synonyms_path":"synonyms/synonym_country.txt",
"type":"synonym",
"ignore_case":true
},
"my_edgeNgram":{
"type":"edgeNGram",
"min_gram":3,
"max_gram":10
}
},
"analyzer":{
"autocomplete":{
"type":"custom",
"tokenizer":"standard",
"filter":[
"standard",
"lowercase",
"syns_filter",
"stop",
"my_edgeNgram"
]
}
},
"mappings":{
"autotest":{
"properties":{
"name":{
"type":"string",
"analyzer":"autocomplete"
}
}
}
}
}
}
}

When i Type "Massachusett"

I get the list of colleges That has "Massachusetts" in there name like

"Massachusetts Bay Community College"
"Middlesex Community College - Massachusetts"
"Springfield College - Massachusetts"
"Massachusetts Institute of Technology"
"Massachusetts School of Barbering"

But i want the college names that start with "Massachusetts" to come on
top
I even tried ngram but still same behavior

Regards
Paul

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/a12674e4-ee39-4ce3-9ebc-af6f98263df4%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/seIEZxxPE-4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAAOGaQKLh2_bX-o2W%3D4n9h3AEOSGMgf4y00w5p-ZTOEUOtG-kg%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAO066G257oLhzCsEpyMroMh2EbnJuxvOBtUr7wvnDOdBVqeQ1w%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(paul) #4

I think if we can boos the results by word position we can solve this issue
, Is there a way to boost the result by the position of the word occurred.

-paul

On Saturday, 18 January 2014 17:25:34 UTC+5:30, paul wrote:

Tried both I also have synonymous in my mapping is that causing the problem
On 18 Jan 2014 00:11, "Amit Soni" amitsoni29@gmail.com wrote:

did you try n-gram or edge n-gram?

-Amit.

On Fri, Jan 17, 2014 at 5:15 AM, paul avinashpaul85@gmail.com wrote:

Hi I am trying out auto-complete below is my mapping

{
"settings":{
"analysis":{
"filter":{
"syns_filter":{
"synonyms_path":"synonyms/synonym_country.txt",
"type":"synonym",
"ignore_case":true
},
"my_edgeNgram":{
"type":"edgeNGram",
"min_gram":3,
"max_gram":10
}
},
"analyzer":{
"autocomplete":{
"type":"custom",
"tokenizer":"standard",
"filter":[
"standard",
"lowercase",
"syns_filter",
"stop",
"my_edgeNgram"
]
}
},
"mappings":{
"autotest":{
"properties":{
"name":{
"type":"string",
"analyzer":"autocomplete"
}
}
}
}
}
}
}

When i Type "Massachusett"

I get the list of colleges That has "Massachusetts" in there name like

"Massachusetts Bay Community College"
"Middlesex Community College - Massachusetts"
"Springfield College - Massachusetts"
"Massachusetts Institute of Technology"
"Massachusetts School of Barbering"

But i want the college names that start with "Massachusetts" to come on
top
I even tried ngram but still same behavior

Regards
Paul

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/a12674e4-ee39-4ce3-9ebc-af6f98263df4%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/seIEZxxPE-4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAAOGaQKLh2_bX-o2W%3D4n9h3AEOSGMgf4y00w5p-ZTOEUOtG-kg%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/07f3f7ba-434c-40fd-a51a-c70309e5eb44%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5