Automatic setting of read_only_allow_delete

We're running elasticsearch version 6.8.8 and 7.7. In both clusters we observed the bahaviour, that the cluster is setting the parameter read_only_allow_delete to true as soon as the fllod stage is reached for some of the indices. The reason is clear to us: During merging the index segments the disk space went near 100% and therefore the parameter was automatically set to true.

BUT: Is there any reason why after merging is done and disk space is (at least 85%) free again the parameter is not set to false automatically?

Since Elasticsearch 7.4 those should be automatically released, see Breaking changes in 7.4 | Elasticsearch Guide [7.13] | Elastic

Can you ensure that the one setting is not accidentally set under Elasticsearch 7.7? If that still keeps happening ,that sounds like a bug to me.

Thanks a lot!! I will check the 7.7 cluster once again, maybe there was a misconfiguration on our side.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.