Avoid monitoring-es-6 logs


(Praveena) #1

Hi,

I'm using platinum license-xpack.
I want to delete the following log, which I got for GET _cat/indices after 5 days.
--green open .monitoring-es-6-2018.07.02 763TW3n4TZmzsNuME-Tu0g 1 0 56676 80 25mb 25mb

my elastisearch.yml :

xpack.monitoring.history.duration: 5d
xpack.monitoring.exporters.my_local:
type: local
use_ingest: false
index.name.time_format: YYYY.MM

Is it correct?
Elasticsearch service is not at all starting if I do this in yml.

Setting only xpack.monitoring.history.duration: 5d is not deleting logs after 5 days.


(Tim Vernum) #2

What error do you get when you try to start the service?


(Praveena) #3

Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Exception in thread "main" [null-valued setting found for key [xpack.monitoring.exporters.my_local] found at line number [37], column number [37]]
at org.elasticsearch.common.settings.Settings.validateValue(Settings.java:759)
at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:723)
at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:673)
at org.elasticsearch.common.settings.Settings.access$500(Settings.java:82)
at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1183)
at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1162)
at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:99)
at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:95)
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)
at org.elasticsearch.cli.Command.main(Command.java:90)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85)


(Ioannis Kakavas) #4

This

xpack.monitoring.exporters.my_local:
type: local
use_ingest: false
index.name.time_format: YYYY.MM

is not valid yaml. Please change this to

xpack.monitoring.exporters.my_local:
  type: local
  use_ingest: false
  index.name.time_format: YYYY.MM

mind the leading SPACE before type,use_ingest and index


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.