AWS Elasticsearch service and filebeat

Hi all.
For testing purposes, I ve installed AWS Elasticsearch service in my account and I have access to kibana. I tried also to send some data with CURL and it's all ok.
Now I was trying to setup filebeat on my laptop and on my k8s cluster on minikube, but I have pretty much the same issue with an error like

Connection marked as failed because the onConnect callback failed: cannot retrieve the elasticsearch license from the /_license endpoint, Filebeat requires the default distribution of Elasticsearch. Please make the endpoint accessible to Filebeat so it can verify the license.: unauthorized access, could not connect to the xpack endpoint, verify your credentials

Exiting: request checking for ILM availability failed: 401 Unauthorized: {"Message":"Your request: '/_xpack' is not allowed."}

I was reading that I need to use filebeat OSS. Is that why I get those errors and not be able to connect/send data to the ELK?



Most probably yes. Can you try with OSS?

Hi Chris. yes I used the OSS version but same error.

To fix this for now I send all the logs from filebeat --> logstash --> Elk... and it's working


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.