AWS RDS module does not poll metrics regularly

Hello Everyone,

I have recently upgraded the Elastic Stack from 7.17.1 to 8.1.2. All the metrics are coming in fine except for AWS RDS which is coming very rarely even though the period is set to 60s.
The IAM user has all the required permissions since metrics are coming (even if rarely). The module YAML is:

- module: aws
  period: 60s
  xpack.enabled: true
    - "rds"
      - "${AWS_REGION}"
  access_key_id: "${AWS_ACCESS_KEY_ID}"
  secret_access_key: "${AWS_SECRET_ACCESS_KEY}"
  default_region: "${AWS_REGION:eu-west-1}"
  timeout: 30s
  connect_timeout: 15s

I tried running metricbeat in debug mode (metricbeat -e -d "*") but couldn't see any request being sent out even after 15 minutes for polling the metrics.
@Kaiyan_Sheng has anything changed in 8.1.2 which I missed as I did check all the release notes and breaking changes before upgrade.

Hi @Ayush_Mathur , thanks for pinging! Quick question: do you know what are the metrics that are missing? I think this might be related to [Metricbeat] aws module rds metricset missing cpu usage · Issue #30915 · elastic/beats · GitHub. I wonder what changed on the AWS side hmmm

Hi @Kaiyan_Sheng , there is no specific metric missing, but the whole poll. It seems even after setting period: 60s, metricbeat is polling for RDS metrics every 6-7 minutes.

Oh no :joy: Let me try to reproduce it locally.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.