Beat's Central Management - Error initializing output: output type undefined

central-management

#1

Hello World!

I'm trying to follow:

and even though through Central Management (Beta)'s Config Status says OK, I'm not seeing any of events in filebeat-* and/or metricbeat-*(

I'm not sure if this is relevant as beat was enrolled for Central Management

# metricbeat test config
Config OK
# metricbeat test output
Error initializing output: output type  undefined
# 

Please advise.


(Mario Castro) #2

Hi @alexus :slight_smile:

Can you paste the contents of your Metricbeat configuration? It doesn't seem an error of Central Management.

I think that the problem is that you don't have an output defined in your Metricbeat configuration file. Check it and ensure you have an uncommented output like:

output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

#3

As I mentioned in earlier, I did enroll of *beat into Central Management, so my config is tiny now:

management:
  enabled: true
  period: 1m0s
  access_token: ${management.accesstoken}
  kibana:
    protocol: https
    host: X:443
    ssl: null
    timeout: 10s
    ignoreversion: true
  blacklist:
    output: console|file

not sure if output.elasticsearch is required anymore, and that is probably why I'm getting an error while doing "test output".


(Mario Castro) #4

Yes, you are right, I didn't tought about it but the test output command relies on what is written in the YML file. It doesn't check with CM yet.

Maybe you can file us an issue on Github if you think it's a good addition :slightly_smiling_face:


(Matthew Apperson) #5

Did you configure an output configuration in CM via a tag assigned to these beats?


#6

yes, an output configuration block was configured in CM via a tag was assigned to these beats.


#7

ok, will file issue on GitHub as I do think it's good addition to say relevant to CM...


(system) closed #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.