Beats with golang version


(Panda) #1

Two month ago, I create my beats according to beats-5.4.3. I installed go 1.7.6. why now it need 1.8.3. Is each version of the beats with a different go version?

according to: https://www.elastic.co/guide/en/beats/devguide/current/beats-contributing.html


(Andrew Kroh) #2

If you are using a vendored copy of elastic/beats@v5.4.3 (from a release tag) then the Go version requirement should not change even if the upstream project moves to a new version.

If you base your project on a branch there are no guarantees. The project will continue to update to new versions of Go to receive bug fixes, security updates, performance enhancements, and new libraries.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.