Beta2 Java Client: java.nio.channels.UnresolvedAddressException


(davrob) #1

Hi,

I'm having difficulty connecting with the Java client to 1.0.0.Beta2, the
cluster is up and health, monitoring is fine using elasticsearch Head,
elasticsearch HQ etc.

This is the stack trace I am getting:

thanks,

David.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6df4a88e-82da-4ef7-ac33-f514e4e50711%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #2

There are FQDNs like vcll36a-1001.equity.csfb.com which can not be resolved
by your DNS settings, it seems.

14 eth interfaces are quite cool to try to connect to, but I would reduce
them by the network interface eth alias names ES provides
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.html

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHj-Vq17bisdYFSmMDHzrih6EkiWQCOoD5JehWpim-N3w%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(davrob) #3

Hi Jorg,

I move to an IP based config to make sure that DNS / FQDNs did not come
into the equation:

Now I get the following:

2014-01-14 16:18:47,278 DEBUG - [Nightwatch] filtered ping responses:
(filter_client[true], filter_data[false]) {none}

2014-01-14 16:18:47,324 DEBUG - [Nightwatch] connected to node
[[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,406 DEBUG - [Nightwatch] connected to node
[[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,407 DEBUG - [Nightwatch] disconnected from
[[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,408 DEBUG - [Nightwatch] filtered ping responses:
(filter_client[true], filter_data[false]) {none}
2014-01-14 16:18:47,450 WARN - [Nightwatch] failed to send ping to
[[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/169.36.78.96:9300]][discovery/zen/unicast] request_id [0] timed
out after [38ms]

The full gist is here: https://gist.github.com/dav-rob/8421114

The server logs look very quiet: https://gist.github.com/dav-rob/8421303

Thanks for you help.

-David.

On Wednesday, 8 January 2014 13:42:25 UTC, Jörg Prante wrote:

There are FQDNs like vcll36a-1001.equity.csfb.com which can not be
resolved by your DNS settings, it seems.

14 eth interfaces are quite cool to try to connect to, but I would reduce
them by the network interface eth alias names ES provides
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.html

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dedd2872-eee6-4a65-9e8d-2e18ac838cba%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

Did you change some settings? Timeout seems to be very low here.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 14 janv. 2014 à 17:39, davrob2 daviroberts@gmail.com a écrit :

Hi Jorg,

I move to an IP based config to make sure that DNS / FQDNs did not come into the equation:

Now I get the following:

2014-01-14 16:18:47,278 DEBUG - [Nightwatch] filtered ping responses: (filter_client[true], filter_data[false]) {none}
2014-01-14 16:18:47,324 DEBUG - [Nightwatch] connected to node [[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,406 DEBUG - [Nightwatch] connected to node [[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,407 DEBUG - [Nightwatch] disconnected from [[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,408 DEBUG - [Nightwatch] filtered ping responses: (filter_client[true], filter_data[false]) {none}
2014-01-14 16:18:47,450 WARN - [Nightwatch] failed to send ping to [[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
org.elasticsearch.transport.ReceiveTimeoutTransportException: [][inet[/169.36.78.96:9300]][discovery/zen/unicast] request_id [0] timed out after [38ms]

The full gist is here: https://gist.github.com/dav-rob/8421114

The server logs look very quiet: https://gist.github.com/dav-rob/8421303

Thanks for you help.

-David.

On Wednesday, 8 January 2014 13:42:25 UTC, Jörg Prante wrote:

There are FQDNs like vcll36a-1001.equity.csfb.com which can not be resolved by your DNS settings, it seems.

14 eth interfaces are quite cool to try to connect to, but I would reduce them by the network interface eth alias names ES provides http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.html

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dedd2872-eee6-4a65-9e8d-2e18ac838cba%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/F8D0C4B4-45E1-45FE-9312-8BFBE753ABAD%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(davrob) #5

Hi David,

Thanks for the reply, actually this all comes down to inheriting some
config that goes back 2 years, which was this:

discovery:
zen:
initial_ping_timeout: 30

I changed this to:

discovery:
zen:
ping_timeout: 30s

all is well now, thanks.

-David.

On Tuesday, 14 January 2014 16:53:28 UTC, David Pilato wrote:

Did you change some settings? Timeout seems to be very low here.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 14 janv. 2014 à 17:39, davrob2 <davir...@gmail.com <javascript:>> a
écrit :

Hi Jorg,

I move to an IP based config to make sure that DNS / FQDNs did not come
into the equation:

Now I get the following:

2014-01-14 16:18:47,278 DEBUG - [Nightwatch] filtered ping responses:
(filter_client[true], filter_data[false]) {none}

2014-01-14 16:18:47,324 DEBUG - [Nightwatch] connected to node
[[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,406 DEBUG - [Nightwatch] connected to node
[[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,407 DEBUG - [Nightwatch] disconnected from
[[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
2014-01-14 16:18:47,408 DEBUG - [Nightwatch] filtered ping responses:
(filter_client[true], filter_data[false]) {none}
2014-01-14 16:18:47,450 WARN - [Nightwatch] failed to send ping to
[[#zen_unicast_1#][inet[/169.36.78.96:9300]]]
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/169.36.78.96:9300]][discovery/zen/unicast] request_id [0] timed
out after [38ms]

The full gist is here: https://gist.github.com/dav-rob/8421114

The server logs look very quiet: https://gist.github.com/dav-rob/8421303

Thanks for you help.

-David.

On Wednesday, 8 January 2014 13:42:25 UTC, Jörg Prante wrote:

There are FQDNs like vcll36a-1001.equity.csfb.com which can not be
resolved by your DNS settings, it seems.

14 eth interfaces are quite cool to try to connect to, but I would reduce
them by the network interface eth alias names ES provides
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.html

Jörg

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/dedd2872-eee6-4a65-9e8d-2e18ac838cba%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0f0d7ab2-e7e4-4ce2-8fc6-f2d440ca1c0f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6