Bigram field


(Igal @ getRailo.org) #1

I'm trying to add a bigram field for use as described at
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-suggesters-phrase.html

I defined a bigram tokenizer like so:

"bigram_tokenizer": {

  "type"       : "nGram"
 ,"min_gram"   : 2
 ,"max_gram"   : 2
 ,"token_chars": [ "letter", "digit" ]

}

and a bigram analyzer like so:

"bigram_analyzer" : {

  "type"        : "custom"
 ,"char_filter" : [ "html_strip" ]
 ,"tokenizer"   : "bigram_tokenizer"
 ,"filter"      : [

      "lowercase"
     ,"asciifolding"
 ]

}

then I'm trying to add a field in the mapping, like so:

 "bigram"       : { "type": "text", "analyzer": "bigram_analyzer" }

but this fails.

any ideas?

thanks!

--
Igal Sapir
Railo Core Developer
http://getRailo.org/

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5359E2AD.2060400%40getrailo.org.
For more options, visit https://groups.google.com/d/optout.


(Igal @ getRailo.org) #2

the error I'm getting is:

 MapperParsingException[No handler for type [text] declared on field 

[bigram];

On 4/24/2014 9:21 PM, Igal @ getRailo.org wrote:

I'm trying to add a bigram field for use as described at
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-suggesters-phrase.html

I defined a bigram tokenizer like so:

"bigram_tokenizer": {

 "type"       : "nGram"
,"min_gram"   : 2
,"max_gram"   : 2
,"token_chars": [ "letter", "digit" ]

}

and a bigram analyzer like so:

"bigram_analyzer" : {

 "type"        : "custom"
,"char_filter" : [ "html_strip" ]
,"tokenizer"   : "bigram_tokenizer"
,"filter"      : [

     "lowercase"
    ,"asciifolding"
]

}

then I'm trying to add a field in the mapping, like so:

"bigram"       : { "type": "text", "analyzer": "bigram_analyzer" }

but this fails.

any ideas?

thanks!

--
Igal Sapir
Railo Core Developer
http://getRailo.org/

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5359EC0F.8030701%40getrailo.org.
For more options, visit https://groups.google.com/d/optout.


(Igal @ getRailo.org) #3

ouch... scratch that. I used "text" instead of "string". need some
sleep I guess...

On 4/24/2014 10:01 PM, Igal @ getRailo.org wrote:

the error I'm getting is:

MapperParsingException[No handler for type [text] declared on 

field [bigram];

On 4/24/2014 9:21 PM, Igal @ getRailo.org wrote:

I'm trying to add a bigram field for use as described at
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-suggesters-phrase.html

I defined a bigram tokenizer like so:

"bigram_tokenizer": {

 "type"       : "nGram"
,"min_gram"   : 2
,"max_gram"   : 2
,"token_chars": [ "letter", "digit" ]

}

and a bigram analyzer like so:

"bigram_analyzer" : {

 "type"        : "custom"
,"char_filter" : [ "html_strip" ]
,"tokenizer"   : "bigram_tokenizer"
,"filter"      : [

     "lowercase"
    ,"asciifolding"
]

}

then I'm trying to add a field in the mapping, like so:

"bigram"       : { "type": "text", "analyzer": "bigram_analyzer" }

but this fails.

any ideas?

thanks!

--
Igal Sapir
Railo Core Developer
http://getRailo.org/

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5359EC58.2020802%40getrailo.org.
For more options, visit https://groups.google.com/d/optout.


(system) #4