Bin/plugin is lying about plugin installation status


(Ben McCann) #1

When I try to install a plugin, elasticsearch tells me that it is
successful, but it actually is not.

$ sudo /usr/share/elasticsearch/bin/plugin --install
richardwilly98/elasticsearch-river-mongodb/1.7.1
-> Installing richardwilly98/elasticsearch-river-mongodb/1.7.1...
Trying
http://download.elasticsearch.org/richardwilly98/elasticsearch-river-mongodb/elasticsearch-river-mongodb-1.7.1.zip...
Trying
http://search.maven.org/remotecontent?filepath=richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying
https://oss.sonatype.org/service/local/repositories/releases/content/richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying
https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/v1.7.1.zip...
Trying
https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/master.zip...
Downloading .................DONE
Installed richardwilly98/elasticsearch-river-mongodb/1.7.1 into
/usr/share/elasticsearch/plugins/river-mongodb

$ sudo ls /usr/share/elasticsearch/plugins/river-mongodb
ls: cannot access /usr/share/elasticsearch/plugins/river-mongodb: No such
file or directory

Any tips on how to get this plugin installed? This seems like a bug in
bin/plugin's status reporting for sure.

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(fatih) #2

Try with -install command. You can check details about this issue on my blog post, because it happened to me long time ago.
http://fatih.karatana.com/elasticsearch-plugin-install/#more-366

I hope it will work.

Fatih.

On Oct 11, 2013, at 9:15 AM, Ben McCann benjamin.j.mccann@gmail.com wrote:

When I try to install a plugin, elasticsearch tells me that it is successful, but it actually is not.

$ sudo /usr/share/elasticsearch/bin/plugin --install richardwilly98/elasticsearch-river-mongodb/1.7.1
-> Installing richardwilly98/elasticsearch-river-mongodb/1.7.1...
Trying http://download.elasticsearch.org/richardwilly98/elasticsearch-river-mongodb/elasticsearch-river-mongodb-1.7.1.zip...
Trying http://search.maven.org/remotecontent?filepath=richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://oss.sonatype.org/service/local/repositories/releases/content/richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/v1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/master.zip...
Downloading .................DONE
Installed richardwilly98/elasticsearch-river-mongodb/1.7.1 into /usr/share/elasticsearch/plugins/river-mongodb

$ sudo ls /usr/share/elasticsearch/plugins/river-mongodb
ls: cannot access /usr/share/elasticsearch/plugins/river-mongodb: No such file or directory

Any tips on how to get this plugin installed? This seems like a bug in bin/plugin's status reporting for sure.

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ben McCann-2) #3

Same thing happened. Thanks for the suggestion though. I'm running 0.90.5,
so I think it should be --install

On Thu, Oct 10, 2013 at 11:30 PM, Fatih Karatana fatih@karatana.com wrote:

Try with -install command. You can check details about this issue on my
blog post, because it happened to me long time ago.
http://fatih.karatana.com/elasticsearch-plugin-install/#more-366

I hope it will work.

Fatih.

On Oct 11, 2013, at 9:15 AM, Ben McCann benjamin.j.mccann@gmail.com
wrote:

When I try to install a plugin, elasticsearch tells me that it is
successful, but it actually is not.

$ sudo /usr/share/elasticsearch/bin/plugin --install
richardwilly98/elasticsearch-river-mongodb/1.7.1
-> Installing richardwilly98/elasticsearch-river-mongodb/1.7.1...
Trying
http://download.elasticsearch.org/richardwilly98/elasticsearch-river-mongodb/elasticsearch-river-mongodb-1.7.1.zip
...
Trying
http://search.maven.org/remotecontent?filepath=richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip
...
Trying
https://oss.sonatype.org/service/local/repositories/releases/content/richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip
...
Trying
https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/v1.7.1.zip
...
Trying
https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/master.zip
...
Downloading .................DONE
Installed richardwilly98/elasticsearch-river-mongodb/1.7.1 into
/usr/share/elasticsearch/plugins/river-mongodb

$ sudo ls /usr/share/elasticsearch/plugins/river-mongodb
ls: cannot access /usr/share/elasticsearch/plugins/river-mongodb: No such
file or directory

Any tips on how to get this plugin installed? This seems like a bug in
bin/plugin's status reporting for sure.

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(fatih) #4

Have you tried with this script? https://github.com/richardwilly98/elasticsearch-river-mongodb/blob/master/install-local.sh

It shows there might be some maven dependencies. May be this causes what you get.

Fatih.

On Oct 11, 2013, at 9:35 AM, Ben McCann ben@benmccann.com wrote:

Same thing happened. Thanks for the suggestion though. I'm running 0.90.5, so I think it should be --install

On Thu, Oct 10, 2013 at 11:30 PM, Fatih Karatana fatih@karatana.com wrote:
Try with -install command. You can check details about this issue on my blog post, because it happened to me long time ago.
http://fatih.karatana.com/elasticsearch-plugin-install/#more-366

I hope it will work.

Fatih.

On Oct 11, 2013, at 9:15 AM, Ben McCann benjamin.j.mccann@gmail.com wrote:

When I try to install a plugin, elasticsearch tells me that it is successful, but it actually is not.

$ sudo /usr/share/elasticsearch/bin/plugin --install richardwilly98/elasticsearch-river-mongodb/1.7.1
-> Installing richardwilly98/elasticsearch-river-mongodb/1.7.1...
Trying http://download.elasticsearch.org/richardwilly98/elasticsearch-river-mongodb/elasticsearch-river-mongodb-1.7.1.zip...
Trying http://search.maven.org/remotecontent?filepath=richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://oss.sonatype.org/service/local/repositories/releases/content/richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/v1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/master.zip...
Downloading .................DONE
Installed richardwilly98/elasticsearch-river-mongodb/1.7.1 into /usr/share/elasticsearch/plugins/river-mongodb

$ sudo ls /usr/share/elasticsearch/plugins/river-mongodb
ls: cannot access /usr/share/elasticsearch/plugins/river-mongodb: No such file or directory

Any tips on how to get this plugin installed? This seems like a bug in bin/plugin's status reporting for sure.

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #5

Both options -install and --install are available.
May be you should run it using sudo?

Wondering though why it said success at the end.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 11 oct. 2013 à 08:35, Ben McCann ben@benmccann.com a écrit :

Same thing happened. Thanks for the suggestion though. I'm running 0.90.5, so I think it should be --install

On Thu, Oct 10, 2013 at 11:30 PM, Fatih Karatana fatih@karatana.com wrote:

Try with -install command. You can check details about this issue on my blog post, because it happened to me long time ago.
http://fatih.karatana.com/elasticsearch-plugin-install/#more-366

I hope it will work.

Fatih.

On Oct 11, 2013, at 9:15 AM, Ben McCann benjamin.j.mccann@gmail.com wrote:

When I try to install a plugin, elasticsearch tells me that it is successful, but it actually is not.

$ sudo /usr/share/elasticsearch/bin/plugin --install richardwilly98/elasticsearch-river-mongodb/1.7.1
-> Installing richardwilly98/elasticsearch-river-mongodb/1.7.1...
Trying http://download.elasticsearch.org/richardwilly98/elasticsearch-river-mongodb/elasticsearch-river-mongodb-1.7.1.zip...
Trying http://search.maven.org/remotecontent?filepath=richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://oss.sonatype.org/service/local/repositories/releases/content/richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/v1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/master.zip...
Downloading .................DONE
Installed richardwilly98/elasticsearch-river-mongodb/1.7.1 into /usr/share/elasticsearch/plugins/river-mongodb

$ sudo ls /usr/share/elasticsearch/plugins/river-mongodb
ls: cannot access /usr/share/elasticsearch/plugins/river-mongodb: No such file or directory

Any tips on how to get this plugin installed? This seems like a bug in bin/plugin's status reporting for sure.

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ben McCann-2) #6

Fatih, That script builds the plugin from source and installs it on your
local machine. It's meant to be used by developers of the plugin and not
users. (I wrote the script :wink:

David, thanks for the suggestion. I did use sudo to run it. Even specifying
the URL does not work:
sudo /usr/share/elasticsearch/bin/plugin --url
https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/elasticsearch-river-mongodb-1.7.1.zip--install
river-mongodb

On Thu, Oct 10, 2013 at 11:57 PM, David Pilato david@pilato.fr wrote:

Both options -install and --install are available.
May be you should run it using sudo?

Wondering though why it said success at the end.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 11 oct. 2013 à 08:35, Ben McCann ben@benmccann.com a écrit :

Same thing happened. Thanks for the suggestion though. I'm running 0.90.5,
so I think it should be --install

On Thu, Oct 10, 2013 at 11:30 PM, Fatih Karatana fatih@karatana.comwrote:

Try with -install command. You can check details about this issue on my
blog post, because it happened to me long time ago.
http://fatih.karatana.com/elasticsearch-plugin-install/#more-366

I hope it will work.

Fatih.

On Oct 11, 2013, at 9:15 AM, Ben McCann benjamin.j.mccann@gmail.com
wrote:

When I try to install a plugin, elasticsearch tells me that it is
successful, but it actually is not.

$ sudo /usr/share/elasticsearch/bin/plugin --install
richardwilly98/elasticsearch-river-mongodb/1.7.1
-> Installing richardwilly98/elasticsearch-river-mongodb/1.7.1...
Trying
http://download.elasticsearch.org/richardwilly98/elasticsearch-river-mongodb/elasticsearch-river-mongodb-1.7.1.zip
...
Trying
http://search.maven.org/remotecontent?filepath=richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip
...
Trying
https://oss.sonatype.org/service/local/repositories/releases/content/richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip
...
Trying
https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/v1.7.1.zip
...
Trying
https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/master.zip
...
Downloading .................DONE
Installed richardwilly98/elasticsearch-river-mongodb/1.7.1 into
/usr/share/elasticsearch/plugins/river-mongodb

$ sudo ls /usr/share/elasticsearch/plugins/river-mongodb
ls: cannot access /usr/share/elasticsearch/plugins/river-mongodb: No such
file or directory

Any tips on how to get this plugin installed? This seems like a bug in
bin/plugin's status reporting for sure.

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(fatih) #7

Then download the zip and extract it into plugin folder manually =) That might work instead of building from source.

Fatih.

On Oct 11, 2013, at 10:01 AM, Ben McCann ben@benmccann.com wrote:

Fatih, That script builds the plugin from source and installs it on your local machine. It's meant to be used by developers of the plugin and not users. (I wrote the script :wink:

David, thanks for the suggestion. I did use sudo to run it. Even specifying the URL does not work:
sudo /usr/share/elasticsearch/bin/plugin --url https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/elasticsearch-river-mongodb-1.7.1.zip --install river-mongodb

On Thu, Oct 10, 2013 at 11:57 PM, David Pilato david@pilato.fr wrote:
Both options -install and --install are available.
May be you should run it using sudo?

Wondering though why it said success at the end.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 11 oct. 2013 à 08:35, Ben McCann ben@benmccann.com a écrit :

Same thing happened. Thanks for the suggestion though. I'm running 0.90.5, so I think it should be --install

On Thu, Oct 10, 2013 at 11:30 PM, Fatih Karatana fatih@karatana.com wrote:
Try with -install command. You can check details about this issue on my blog post, because it happened to me long time ago.
http://fatih.karatana.com/elasticsearch-plugin-install/#more-366

I hope it will work.

Fatih.

On Oct 11, 2013, at 9:15 AM, Ben McCann benjamin.j.mccann@gmail.com wrote:

When I try to install a plugin, elasticsearch tells me that it is successful, but it actually is not.

$ sudo /usr/share/elasticsearch/bin/plugin --install richardwilly98/elasticsearch-river-mongodb/1.7.1
-> Installing richardwilly98/elasticsearch-river-mongodb/1.7.1...
Trying http://download.elasticsearch.org/richardwilly98/elasticsearch-river-mongodb/elasticsearch-river-mongodb-1.7.1.zip...
Trying http://search.maven.org/remotecontent?filepath=richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://oss.sonatype.org/service/local/repositories/releases/content/richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/v1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/master.zip...
Downloading .................DONE
Installed richardwilly98/elasticsearch-river-mongodb/1.7.1 into /usr/share/elasticsearch/plugins/river-mongodb

$ sudo ls /usr/share/elasticsearch/plugins/river-mongodb
ls: cannot access /usr/share/elasticsearch/plugins/river-mongodb: No such file or directory

Any tips on how to get this plugin installed? This seems like a bug in bin/plugin's status reporting for sure.

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #8

Could you try with the --verbose option as well?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 11 oct. 2013 à 09:01, Ben McCann ben@benmccann.com a écrit :

Fatih, That script builds the plugin from source and installs it on your local machine. It's meant to be used by developers of the plugin and not users. (I wrote the script :wink:

David, thanks for the suggestion. I did use sudo to run it. Even specifying the URL does not work:
sudo /usr/share/elasticsearch/bin/plugin --url https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/elasticsearch-river-mongodb-1.7.1.zip --install river-mongodb

On Thu, Oct 10, 2013 at 11:57 PM, David Pilato david@pilato.fr wrote:
Both options -install and --install are available.
May be you should run it using sudo?

Wondering though why it said success at the end.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 11 oct. 2013 à 08:35, Ben McCann ben@benmccann.com a écrit :

Same thing happened. Thanks for the suggestion though. I'm running 0.90.5, so I think it should be --install

On Thu, Oct 10, 2013 at 11:30 PM, Fatih Karatana fatih@karatana.com wrote:
Try with -install command. You can check details about this issue on my blog post, because it happened to me long time ago.
http://fatih.karatana.com/elasticsearch-plugin-install/#more-366

I hope it will work.

Fatih.

On Oct 11, 2013, at 9:15 AM, Ben McCann benjamin.j.mccann@gmail.com wrote:

When I try to install a plugin, elasticsearch tells me that it is successful, but it actually is not.

$ sudo /usr/share/elasticsearch/bin/plugin --install richardwilly98/elasticsearch-river-mongodb/1.7.1
-> Installing richardwilly98/elasticsearch-river-mongodb/1.7.1...
Trying http://download.elasticsearch.org/richardwilly98/elasticsearch-river-mongodb/elasticsearch-river-mongodb-1.7.1.zip...
Trying http://search.maven.org/remotecontent?filepath=richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://oss.sonatype.org/service/local/repositories/releases/content/richardwilly98/elasticsearch-river-mongodb/1.7.1/elasticsearch-river-mongodb-1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/v1.7.1.zip...
Trying https://github.com/richardwilly98/elasticsearch-river-mongodb/archive/master.zip...
Downloading .................DONE
Installed richardwilly98/elasticsearch-river-mongodb/1.7.1 into /usr/share/elasticsearch/plugins/river-mongodb

$ sudo ls /usr/share/elasticsearch/plugins/river-mongodb
ls: cannot access /usr/share/elasticsearch/plugins/river-mongodb: No such file or directory

Any tips on how to get this plugin installed? This seems like a bug in bin/plugin's status reporting for sure.

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/ndWuJlYDn5w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
about.me/benmccann

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ben McCann-2) #9

Ahh, the --verbose option helped.

Turns out I was supposed to do this:
sudo /usr/share/elasticsearch/bin/plugin -i
com.github.richardwilly98.elasticsearch/elasticsearch-river-mongodb/1.7.1

I filed a bug for the bad output from bin/plugin. It took me awhile to even
realize I had a problem installing it given the output

Thanks for the help!

-Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #10