Binding to Public / Private IPs


(Olu) #1

ElasticSearch noob here.

How do I specify the IP address that ES binds to??

I have an EC2 instance that runs ES on it. curling localhost:9200 on that
machine provides me with ES data. However, trying to query ES using the
public IP address of the EC2 instance (curl
http://<public_ip_address>:9200/_search?...), this does not work.

I have turned off all firewalls on the server. iptables and ip6tables have
all been turned on. Port 9200 and 9300 (default ports ES uses) are also
open.

Taking a look at the logs, I can see the ES binds to the private IP address
of the ec2 instance when starting up. I've tried changing the network
bind_host, publish_host variables to the explicit public IP address but ES
still binds to the private IP address when starting.

I'm not sure what else to try. Trying to set up Kibana fails with this
setup, b/c even though KIbana and ES are on the same server, Kibana is
using the the url http://<public_ip_address>:9200 to try to connect to ES
but it cannot connect using that url.

There might be an easy solution to this but any help in solving this would
be greatly appreciated.

Thanks!!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1f74bfc7-2784-4053-8944-4a1048a2a04e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #2

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.htmlwill
help

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 4 February 2014 07:07, Olu oowoseni@gmail.com wrote:

ElasticSearch noob here.

How do I specify the IP address that ES binds to??

I have an EC2 instance that runs ES on it. curling localhost:9200 on that
machine provides me with ES data. However, trying to query ES using the
public IP address of the EC2 instance (curl http://<public_ip_address>:9200/_search?...),
this does not work.

I have turned off all firewalls on the server. iptables and ip6tables have
all been turned on. Port 9200 and 9300 (default ports ES uses) are also
open.

Taking a look at the logs, I can see the ES binds to the private IP
address of the ec2 instance when starting up. I've tried changing the
network bind_host, publish_host variables to the explicit public IP address
but ES still binds to the private IP address when starting.

I'm not sure what else to try. Trying to set up Kibana fails with this
setup, b/c even though KIbana and ES are on the same server, Kibana is
using the the url http://<public_ip_address>:9200 to try to connect to ES
but it cannot connect using that url.

There might be an easy solution to this but any help in solving this would
be greatly appreciated.

Thanks!!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1f74bfc7-2784-4053-8944-4a1048a2a04e%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624bdPubFoBzn-rXdaCkPA8Er7J-zARMEVbBPLmSBCi_bzw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Olu) #3

I've tried taking a look at the network settings. I've even downloaded the
cloud-aws plugin and tried changing the host settings to no avail.

On Monday, February 3, 2014 4:04:35 PM UTC-5, Mark Walkom wrote:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.htmlwill help

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 4 February 2014 07:07, Olu <oowo...@gmail.com <javascript:>> wrote:

ElasticSearch noob here.

How do I specify the IP address that ES binds to??

I have an EC2 instance that runs ES on it. curling localhost:9200 on that
machine provides me with ES data. However, trying to query ES using the
public IP address of the EC2 instance (curl
http://<public_ip_address>:9200/_search?...), this does not work.

I have turned off all firewalls on the server. iptables and ip6tables
have all been turned on. Port 9200 and 9300 (default ports ES uses) are
also open.

Taking a look at the logs, I can see the ES binds to the private IP
address of the ec2 instance when starting up. I've tried changing the
network bind_host, publish_host variables to the explicit public IP address
but ES still binds to the private IP address when starting.

I'm not sure what else to try. Trying to set up Kibana fails with this
setup, b/c even though KIbana and ES are on the same server, Kibana is
using the the url http://<public_ip_address>:9200 to try to connect to ES
but it cannot connect using that url.

There might be an easy solution to this but any help in solving this
would be greatly appreciated.

Thanks!!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1f74bfc7-2784-4053-8944-4a1048a2a04e%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ea6c73b3-8b7a-4b8d-a417-2d0461f220e2%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tony Su) #4

Although I haven't tried to configure what you asked about, I am interested.
Based on the link Mark posted,
Did you uncomment and try to configure the settings in
/etc/elasticsearch/elasticsearch.yml ?

If I understand the documentation correctly, that is what you likely need
to do if you don't use the plugin.

Tony

On Monday, February 3, 2014 1:07:57 PM UTC-8, Tom Jackson wrote:

I've tried taking a look at the network settings. I've even downloaded the
cloud-aws plugin and tried changing the host settings to no avail.

On Monday, February 3, 2014 4:04:35 PM UTC-5, Mark Walkom wrote:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.htmlwill help

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 4 February 2014 07:07, Olu oowo...@gmail.com wrote:

ElasticSearch noob here.

How do I specify the IP address that ES binds to??

I have an EC2 instance that runs ES on it. curling localhost:9200 on
that machine provides me with ES data. However, trying to query ES using
the public IP address of the EC2 instance (curl
http://<public_ip_address>:9200/_search?...), this does not work.

I have turned off all firewalls on the server. iptables and ip6tables
have all been turned on. Port 9200 and 9300 (default ports ES uses) are
also open.

Taking a look at the logs, I can see the ES binds to the private IP
address of the ec2 instance when starting up. I've tried changing the
network bind_host, publish_host variables to the explicit public IP address
but ES still binds to the private IP address when starting.

I'm not sure what else to try. Trying to set up Kibana fails with this
setup, b/c even though KIbana and ES are on the same server, Kibana is
using the the url http://<public_ip_address>:9200 to try to connect to ES
but it cannot connect using that url.

There might be an easy solution to this but any help in solving this
would be greatly appreciated.

Thanks!!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1f74bfc7-2784-4053-8944-4a1048a2a04e%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7d0a95af-8b20-4ce7-a681-b36967d7ff0a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5