Boolean multi-field silently ignored in 1.2.1


(Bruce Ritchie) #1

I'm seeing multi-fields of type boolean silently being reduced to a normal
boolean field in 1.2.1 which wasn't the behavior in 0.90.9.
See https://gist.github.com/Omega359/0c2a93690b4db30693a1 for an example of
this.

Is this expected? To me it seems like it should work - the boolean field
mapper seems to be calling out to multiFieldsBuilder - but I'm not versed
enough in the internals of ES to know where if at all it's broken.

Bruce

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ccc5b263-24a2-45c5-97d1-46a93799eb58%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Clinton Gormley) #2

heya bruce

that looks like a bug - please open an issue

clint

On 20 June 2014 19:41, Bruce Ritchie bruce.ritchie@gmail.com wrote:

I'm seeing multi-fields of type boolean silently being reduced to a normal
boolean field in 1.2.1 which wasn't the behavior in 0.90.9. See
https://gist.github.com/Omega359/0c2a93690b4db30693a1 for an example of
this.

Is this expected? To me it seems like it should work - the boolean field
mapper seems to be calling out to multiFieldsBuilder - but I'm not versed
enough in the internals of ES to know where if at all it's broken.

Bruce

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ccc5b263-24a2-45c5-97d1-46a93799eb58%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ccc5b263-24a2-45c5-97d1-46a93799eb58%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAPt3XKSpOKM38EJDpVkXyTdNuKtL%2BE5dDHBEV89K2LPP4oS2-A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3