"Bootstrap check failed" still a mystery?


(Nikhil Jaiswal) #1

Hi,

I read many threads related to "Bootstrap check failed" but didn't get any solution.

I am using elasticsearch for production environment.

below is my ES configuration

clustername: elasticsearch
node.name: xyz
node.master: true
node.data: true
path.data: /var/elasticseaarch/data
patah.logs: /var/elasticsearch/logs
network.host: 192.168.8.12
transport.port: 9300
discovery.zen.ping.unicast.hosts: ["192.168.8.11", "192.168.8.12", "192.168.8.13"]
discovery.zen.minimum_master_node: 2

OS and ES version

ES  version: 5.6.12
Linux Version: Redhat 7.6
Kernel version: 3.10.0

I tried with all the configuration which I got in other threads for example:

network.host: _eth0_
transport.host: localhost

Unfortunately no luck

Error logs are below:

[2018-12-12T14:16:13,023][INFO ][o.e.b.BootstrapCheck ] [ssosearch01] bound or publishing 
to a non-loopback or non-link-local address, enforcing bootstrap checks

[2018-12-12T14:16:13,024][ERROR][o.e.b.Bootstrap ] [ssosearch01] node validation 
exception bootstrap checks failed

I am trying to resolve this issue from the past 2 days.

Any help would be appriciated.


(David Pilato) #2

After this line you should see more details about the failure.
Please read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html


(Nikhil Jaiswal) #3

I went through the link thrice but still not clear where i am doing wrong.


(Nikhil Jaiswal) #4

Please find the screenshot of error log as machine is in production i am not able to copy paste logs here here.


(David Pilato) #5

Please don't post images of text as they are hardly readable and not searchable.

Instead paste the text and format it with </> icon. Check the preview window.

Read this page: https://www.elastic.co/guide/en/elasticsearch/reference/current/_system_call_filter_check.html


(Prashant Rana) #6

try disabling system call filters using this setting " bootstrap.system_call_filter: false" in your elasticsearch.yml file.


(Nikhil Jaiswal) #7

Apologies for that. As i mentioned before, logs are in production server which doesn't have internet connectivity i am not able to copy paste the logs.

After adding "bootstrap.system_call_filter: false" i am able to start the service but not able to connect to http://localhost:9200

Error logs:

# curl -XGET 'http://localhost:9200/'
 curl: (7) Failed connect to localhost:9200; Connection refused

But i verified service is running.


(Nikhil Jaiswal) #8

Thanks for the reply

After adding "bootstrap.system_call_filter: false" i am able to start the service but not able to connect to http://localhost:9200

Error logs:

 # curl -XGET 'http://localhost:9200/'
 curl: (7) Failed connect to localhost:9200; Connection refused

But i verified service is running.


(David Pilato) #9

Check again the logs and look for the line where port 9200 is mentioned. You'll see what is the IP address to use.


(Nikhil Jaiswal) #10

I am getting same IP which i have given in the configuration.

publish_address (192.168.8.12:9200),  bound_addresses (192.168.8.12:9200)

(David Pilato) #11

So don't run:

curl -XGET 'http://localhost:9200/'

But:

curl -XGET 'http://192.168.8.12:9200/'

(Nikhil Jaiswal) #12

Yes, It worked

Thanks a lot.