Bootstrap error elasticsearch-7.1.1

I'm using elasticsearch-7.1.1 on Ubuntu 19.04 with elasticasearch being source compiled *.tar.gz

On the logs, I get as i start to start

./elasticsearch -d -p PID

     2019-06-11T13:24:42,520][INFO ][o.e.p.PluginsService     ] [elk] loaded module [x-pack-watcher]
         [2019-06-11T13:24:42,520][INFO ][o.e.p.PluginsService     ] [elk] no plugins loaded
         [2019-06-11T13:24:45,128][ERROR][o.e.b.Bootstrap          ] [elk] Exception
         java.lang.IllegalArgumentException: unknown setting [es_enable_xpack] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
                 at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:531) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:476) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:447) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:418) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.common.settings.SettingsModule.<init>(SettingsModule.java:148) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.node.Node.<init>(Node.java:343) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.node.Node.<init>(Node.java:252) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:211) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:211) ~[elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) [elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-7.1.1.jar:7.1.1]
                 at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.1.1.jar:7.1.1]
                 at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) [elasticsearch-7.1.1.jar:7.1.1]
                 at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.1.1.jar:7.1.1]
                 Suppressed: java.lang.Ille

I have changed elasticsearch.yml to add the following:-

network.host: [local, site, global]
cluster.initial_master_nodes: node-1
name: "NETWORK_HOST"
value: "ens160:ipv4"
es_enable_xpack: false
es_xpack_features: ["alerting","monitoring","graph","ml","security"]

In order to get it remote network login over 5601 port. Thanks

The parameter “es_enable_xpack” is not valid.
#I think “es_xpack_features” is also invalid.

You can configure like this.

    xpack.security.enabled: false
    xpack.monitoring.enabled: false

Thanks.

1 Like

Thanks I solved the problem
added these lines to elasticsearch.yml

network.host: local:ipv4_
network.publish_host: 127.0.0.1
http.port: 9200
transport.tcp.port: 9300
discovery.type: single-node

Problem now is that I'm unable to connect remotely.

Your settings seem to expect only local access.
If you need to connect remotely please use this:

network.host: 0.0.0.0
# network.publish_host: 127.0.0.1
# http.port: 9200
# transport.tcp.port: 9300
# discovery.type: single-node
discovery.seed_hosts:
   - master-node-a
   - master-node-b
   - master-node-c
cluster.initial_master_nodes: 
   - master-node-a
   - master-node-b
   - master-node-c

Ref:https://www.elastic.co/guide/en/elasticsearch/reference/current/discovery-settings.html#initial_master_nodes

1 Like

After changes I get following error messages

[2019-06-12T08:12:02,929][INFO ][o.e.t.TransportService ] [elk] publish_address {10.27.0.4:9300}, bound_addresses {0.0.0.0:9300}
[2019-06-12T08:12:02,938][INFO ][o.e.b.BootstrapChecks ] [elk] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2019-06-12T08:12:02,963][ERROR][o.e.b.Bootstrap ] [elk] node validation exception
[1] bootstrap checks failed
[1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
[2019-06-12T08:12:02,972][INFO ][o.e.n.Node ] [elk] stopping ...
[2019-06-12T08:12:03,014][INFO ][o.e.n.Node ] [elk] stopped
[2019-06-12T08:12:03,014][INFO ][o.e.n.Node ] [elk] closing ...
[2019-06-12T08:12:03,027][INFO ][o.e.n.Node ] [elk] closed
[2019-06-12T08:12:03,029][INFO ][o.e.x.m.p.NativeController] [elk] Native controller process has stopped - no new native processes can be started

Follow this one.
https://www.elastic.co/guide/en/elasticsearch/reference/current/vm-max-map-count.html

1 Like

The problem still exists,

tcp 0 0 0.0.0.0:9200 0.0.0.0:* LISTEN 2044/java
tcp 0 0 0.0.0.0:9300 0.0.0.0:* LISTEN 2044/java
tcp 0 0 127.0.0.53:53 0.0.0.0:* LISTEN 850/systemd-resolve
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1080/sshd
tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN 2104/./../node/bin/
tcp6 0 0 :::22 :::* LISTEN 1080/sshd

[2019-06-12T09:01:18,555][INFO ][o.e.c.s.MasterService ] [elk] elected-as-master ([1] nodes joined)[{elk}{tJl3X-bPRp62gGp_Gtj8UQ}{nfLXSsfyQfG52rmdX8iD_w}{10.27.0.4}{10.27.0.4:9300}{ml.machine_memory=4058173440, xpack.installed=true, ml.max_open_jobs=20} elect leader, BECOME_MASTER_TASK, FINISH_ELECTION], term: 11, version: 71, reason: master node changed {previous , current [{elk}{tJl3X-bPRp62gGp_Gtj8UQ}{nfLXSsfyQfG52rmdX8iD_w}{10.27.0.4}{10.27.0.4:9300}{ml.machine_memory=4058173440, xpack.installed=true, ml.max_open_jobs=20}]}
[2019-06-12T09:01:18,798][INFO ][o.e.c.s.ClusterApplierService] [elk] master node changed {previous , current [{elk}{tJl3X-bPRp62gGp_Gtj8UQ}{nfLXSsfyQfG52rmdX8iD_w}{10.27.0.4}{10.27.0.4:9300}{ml.machine_memory=4058173440, xpack.installed=true, ml.max_open_jobs=20}]}, term: 11, version: 71, reason: Publication{term=11, version=71}
[2019-06-12T09:01:18,894][INFO ][o.e.h.AbstractHttpServerTransport] [elk] publish_address {10.27.0.4:9200}, bound_addresses {0.0.0.0:9200}
[2019-06-12T09:01:18,894][INFO ][o.e.n.Node ] [elk] started
[2019-06-12T09:01:19,114][WARN ][o.e.x.s.a.s.m.NativeRoleMappingStore] [elk] Failed to clear cache for realms []
[2019-06-12T09:01:19,169][INFO ][o.e.l.LicenseService ] [elk] license [322fc376-9415-4200-bc3d-9101503d0b44] mode [basic] - valid
[2019-06-12T09:01:19,181][INFO ][o.e.g.GatewayService ] [elk] recovered [2] indices into cluster_state
[2019-06-12T09:01:19,934][INFO ][o.e.c.r.a.AllocationService] [elk] Cluster health status changed from [RED] to [GREEN] (reason: [shards started [[.kibana_task_manager][0]] ...]).
[2019-06-12T09:01:42,630][INFO ][o.e.c.m.MetaDataIndexTemplateService] [elk] adding template [.management-beats] for index patterns [.management-beat

I'm afraid, it looks fine for me. What is current problem?

1 Like

when I try to telnet to ports 9200 , 9300 and 5601 from remote machine it doesn't connects same is when I open with browser. I see , the ufw is turned off, and iptables is also default policy with no explicit deny statements.

The netstat , show the ports in listening mode as well.

yml file show as :-
> network.host: _local_
> discovery.seed_hosts: ["host1", "host2", "host3"]
> cluster.initial_master_nodes: ["node-1", "node-2", "node-3"]

Problem is solved
edited kibana.yml

server.host: 0.0.0.0

1 Like