Bound or publishing to a non-loopback address, enforcing bootstrap checks

Hi ,
i decied to use elastic on linux centos but i cant resolved below issue. I have two servers with same configurations. Elastic works separately but cannot be cluster and i see log below.
Elasticsearch version is 7.3.1

[2019-09-12T15:23:22,043][INFO ][o.e.p.PluginsService ] [node-1] loaded module [percolator]
[2019-09-12T15:23:22,043][INFO ][o.e.p.PluginsService ] [node-1] loaded module [rank-eval]
[2019-09-12T15:23:22,044][INFO ][o.e.p.PluginsService ] [node-1] loaded module [reindex]
[2019-09-12T15:23:22,044][INFO ][o.e.p.PluginsService ] [node-1] loaded module [repository-url]
[2019-09-12T15:23:22,045][INFO ][o.e.p.PluginsService ] [node-1] loaded module [transport-netty4]
[2019-09-12T15:23:22,045][INFO ][o.e.p.PluginsService ] [node-1] loaded module [vectors]
[2019-09-12T15:23:22,045][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-ccr]
[2019-09-12T15:23:22,046][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-core]
[2019-09-12T15:23:22,046][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-deprecation]
[2019-09-12T15:23:22,047][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-graph]
[2019-09-12T15:23:22,047][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-ilm]
[2019-09-12T15:23:22,048][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-logstash]
[2019-09-12T15:23:22,048][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-ml]
[2019-09-12T15:23:22,048][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-monitoring]
[2019-09-12T15:23:22,049][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-rollup]
[2019-09-12T15:23:22,050][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-security]
[2019-09-12T15:23:22,050][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-sql]
[2019-09-12T15:23:22,051][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-voting-only-node]
[2019-09-12T15:23:22,051][INFO ][o.e.p.PluginsService ] [node-1] loaded module [x-pack-watcher]
[2019-09-12T15:23:22,052][INFO ][o.e.p.PluginsService ] [node-1] no plugins loaded
[2019-09-12T15:23:29,049][INFO ][o.e.x.s.a.s.FileRolesStore] [node-1] parsed [0] roles from file [/etc/elasticsearch/roles.yml]
[2019-09-12T15:23:30,521][INFO ][o.e.x.m.p.l.CppLogMessageHandler] [node-1] [controller/1948] [Main.cc@110] controller (64 bit): Version 7.3.1 (Build 1d93901e09ef43) Copyright (c) 2019 Elasticsearch BV
[2019-09-12T15:23:31,488][DEBUG][o.e.a.ActionModule ] [node-1] Using REST wrapper from plugin org.elasticsearch.xpack.security.Security
[2019-09-12T15:23:32,095][INFO ][o.e.d.DiscoveryModule ] [node-1] using discovery type [zen] and seed hosts providers [settings]
[2019-09-12T15:23:33,449][INFO ][o.e.n.Node ] [node-1] initialized
[2019-09-12T15:23:33,449][INFO ][o.e.n.Node ] [node-1] starting ...
[2019-09-12T15:23:33,732][INFO ][o.e.t.TransportService ] [node-1] publish_address {PUBLICIP:9300}, bound_addresses {[::]:9300}
[2019-09-12T15:23:33,742][INFO ][o.e.b.BootstrapChecks ] [node-1] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2019-09-12T15:23:33,802][INFO ][o.e.c.c.Coordinator ] [node-1] cluster UUID [0WlayW6tTKWt9Wlz2uj-ZA]
[2019-09-12T15:23:34,080][INFO ][o.e.c.s.MasterService ] [node-1] elected-as-master ([1] nodes joined)[{node-1}{8Jc2DfhjRg2au-tgRu7HMQ}{gnjUgge_So6_w23tYrkOdw}{PUBLICIP}{PUBLICIP:9300}{dim}{ml.machine_memory=3954171904, xpack.installed=true, ml.max_open_jobs=20} elect leader, BECOME_MASTER_TASK, FINISH_ELECTION], term: 56, version: 121, reason: master node changed {previous , current [{node-1}{8Jc2DfhjRg2au-tgRu7HMQ}{gnjUgge_So6_w23tYrkOdw}{PUBLICIP}{PUBLICIP:9300}{dim}{ml.machine_memory=3954171904, xpack.installed=true, ml.max_open_jobs=20}]}
[2019-09-12T15:23:34,221][INFO ][o.e.c.s.ClusterApplierService] [node-1] master node changed {previous , current [{node-1}{8Jc2DfhjRg2au-tgRu7HMQ}{gnjUgge_So6_w23tYrkOdw}{PUBLICIP}{PUBLICIP:9300}{dim}{ml.machine_memory=3954171904, xpack.installed=true, ml.max_open_jobs=20}]}, term: 56, version: 121, reason: Publication{term=56, version=121}
[2019-09-12T15:23:34,297][INFO ][o.e.h.AbstractHttpServerTransport] [node-1] publish_address {PUBLICIP:9200}, bound_addresses {[::]:9200}
[2019-09-12T15:23:34,298][INFO ][o.e.n.Node ] [node-1] started
[2019-09-12T15:23:34,697][INFO ][o.e.l.LicenseService ] [node-1] license [bd74b3a7-c8ee-40a4-b84c-c06711b530fd] mode [basic] - valid
[2019-09-12T15:23:34,698][INFO ][o.e.x.s.s.SecurityStatusChangeListener] [node-1] Active license is now [BASIC]; Security is disabled
[2019-09-12T15:23:34,716][INFO ][o.e.g.GatewayService ] [node-1] recovered [0] indices into cluster_state

Everything looks good here - Elasticsearch has started up normally. In particular the message in the title of your post, "Bound or publishing to a non-loopback address, enforcing bootstrap checks", doesn't indicate any issue.

Thank you for quick answer. I cant see other node when i run _cat/nodes
my config file
cluster.name: my-application
node.name: node-1
node.master: true
node.data: true
node.ingest :false
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
bootstrap.memory_lock: true
network.host: 0.0.0.0
discovery.seed_hosts: ["PUBLICIP-1", "PUBLICIP-2"]
cluster.initial_master_nodes: ["node-1", "node-2"]

Does the other node report a different cluster UUID in its log? If so, see this note in the docs for more information, and instructions on how to resolve it.

yes, they are different.

I made configuration like below at first but stil get same result :frowning:

cluster.name: my-application
node.name: node-1
node.master: true
node.data: true
node.ingest :false
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
bootstrap.memory_lock: true
network.host: 0.0.0.0
discovery.seed_hosts: ["PUBLICIP-1", "PUBLICIP-2"]
cluster.initial_master_nodes: ["node-1", "node-2"]

Yes, you need to read the note in the docs I linked above.