Broken relevance

I am using elastic search for search purposes. My configuration has 3 shards and 2 replicas. One of the type of record has only 2.6 million records. When performing a simple match query against a field, it returns different results each time. I have tried using DFS query but makes no difference. Still get 3 different kind of responses.

Did any of you face this issue and how did you solve it?

What does the query look like?
What version are you on?


{"from":0,"size":1, "query": {"match": {"field_name": "query_string"}}}

Version 5.1.2

Have you set explain: true on your query? Can you see why Elasticsearch scores the documents differently? (hint a Splainer can help you visualize the explain)

splain is a good idea, but my es instances are behind a firewall and cannot be reached externally. Forget CORS.

Do you have a staging or development instance that replicated production?
Always a good idea IMO to help troubleshoot these sort of issues.

yes we do and all are behind firewall.

In any case can you set explain: true on the query to see the relevance
scoring debug?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.