BUG assigning ILM policy to _index_template

How I can assign ILM Policy to _index_template

I found this tutorial:

I have version 7.9 and in older version (_template) there was a button add policy to index template
in recent version 7.9 _index_template is not visible from GUI

its the only way to do the assignment via settings and adding these 2 lines there?

      "index.lifecycle.name": "timeseries_policy",      
      "index.lifecycle.rollover_alias": "timeseries"

you can do it via dev tools and template api.

or

stack management > index management > index templates > your-index > edit > index settings

{
  "index": {
    "lifecycle": {
      "name": "ilm-name"
    },
    "number_of_shards": "1",
    "number_of_replicas": "1",
...
...
  }
}

@AClerk, thank you. this was the question. Is this the only option.
In older version there was a GUI click assignment option (as I added in picture).
Now I have to copy the ILM + ALIAS into settings. So it seems Elastic give-up on this gui feature.
thank u

@AClerk it is weird in index template creation Elastic did everything GUI based.
I can click component_template
I can click data types

but assigning ILM is done by remembering and writing the text into text box field.
It seems to me very inconsistent from end-user perspective.

I suppose it is a BUG!
from the documentation
see https://www.elastic.co/guide/en/elasticsearch/reference/current/index-lifecycle-management.html
the first picture on recent documentation declares the option
but this feature NOT WORKING!

1 Like