Bulk index


(Ada) #1

I am still on ES 2.4. After bulk index is done,

  1. update the following settings:
    {"number_of_replicas":1, "refresh_interval":"30ms"} as I set refresh_interval to 5s and number_of_replicas to 0 before indexing.
  2. closed the new index
  3. update this:
    "transient" : {
    "indices.store.throttle.type" : "merge"
    },
  4. open the new index;
  5. check the count of the new index. If the new count is ok comparing with the old count, I will switch the new index with the alias.

This was working.

But now I tried to set "refresh_interval" to -1 before indexing;
After bulk index is done, I refreshed the index: client.admin().indices().prepareRefresh().get() as I set refresh_interval to -1;

but while I tried to get the count of the new index, it reported error:

RemoteTransportException[[Kehl of Tauran][127.0.0.1:9300][indices:data/read/search[phase/query]]]; nested: IndexNotFoundException[no such index];
Caused by: [new_index_name] IndexNotFoundException[no such index]

...

[2017-05-24 14:52:22,766][INFO ][cluster.routing.allocation] [Kehl of Tauran] Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[new_index_name][0], [new_index_name][0], [new_index_name][1]] ...]).

Seems elasticsearch shards are not on the right status. What should be done in what order when refresh_interval is set to -1?

Thanks


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.