Can not disable _all field

Hi, everyone
I upgrade ES from 5.4.0 to 6.8.0.
Now I want to disable _all field in my index and I get a error:

curl -XPUT -d'
"mappings": {
"human": {
"_all": {
"enabled": false

{"error":{"root_cause":[{"type":"resource_already_exists_exception","reason":"index [dzwl-d406-imsiimei20190703/wqC7apwuREm6e6OsY3lLzA] already exists","index_uuid":"wqC7apwuREm6e6OsY3lLzA","index":"dzwl-d406-imsiimei20190703"}],"type":"resource_already_exists_exception","reason":"index [dzwl-d406-imsiimei20190703/wqC7apwuREm6e6OsY3lLzA] already exists","index_uuid":"wqC7apwuREm6e6OsY3lLzA","index":"dzwl-d406-imsiimei20190703"},"status":400}[root@hadoop-5 waitupdate]#

How can I disable _all field in ES?
thank you very much.

You cannot disable it on an index that already exists, you will need to reindex into a new index with that mapping applied.

Thank you and best regards.

In addition, just to keep in mind that there is no _all feature in >6.x versions. (+info).

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.