Can not send alert via gmail(already disable 2FA)

alerting

(鄒禕庭) #1

Can not send alert via gmail(already disable 2FA)
I am sure my password and account is right! And I already disabled 2 factors authtications.
The log is
//at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
Caused by: javax.mail.AuthenticationFailedException: 535-5.7.8 Username and Password not accepted. Learn more at
535 5.7.8 https://support.google.com/mail/?p=BadCredentials q128-v6sm724693pfb.160 - gsmtp

My elasticsearch.yml :
// bootstrap.memory_lock: false
cluster.name: elasticsearch
http.port: 9200
node.data: true
node.ingest: true
node.master: true
node.max_local_storage_nodes: 1
node.name: DESKTOP-JO30UQR
path.data: C:\ProgramData\Elastic\Elasticsearch\data
path.logs: C:\ProgramData\Elastic\Elasticsearch\logs
transport.tcp.port: 9300
xpack.license.self_generated.type: basic
xpack.security.enabled: false
xpack.notification.email.account:
gmail_account:
profile: gmail
smtp:
auth: true
starttls.enable: true
host: smtp.gmail.com
port: 587
user: sailorjupiterXXXXX@gmail.com
password: HDUSDWUWS*


(Senthil kumar mohan) #2

Pls check if you have enabled access to the less secure apps. https://support.google.com/accounts/answer/6010255


(鄒禕庭) #3

Yes, I already done it, too. But the alert still can't send.

Senthil kumar mohan elastic@discoursemail.com 於 2018年10月29日 週一 12:57 寫道:


(Alexander Reelsen) #4

I think it makes sense to remove watcher from the equation and check if you can send email via the google mail API manually. The exception still states that there is an authentication error against google mail, which very unlikely stems from watcher.

--Alex


(鄒禕庭) #5

Could you please teach me how to send

email via the google mail API manually?

Thank you very much!

Alexander Reelsen elastic@discoursemail.com 於 2018年10月29日 週一 18:07 寫道:


(鄒禕庭) #6

Suddenly it OK without doing anything


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.