Cannot create a repository in Elasticsearch in order to take a backup

Hello Elastic community,

I'm unable to create a repository in order to take a backup of my cluster. I do have root permissions to the cluster and yes, a backup share has been created which is shared across all nodes on the cluster. This is the error I'm getting (the company's also using Puppet for managing the configuration of the yaml files) but I'm getting the below error, /backup is the path in the path.repo config)

curl -X PUT "localhost:9200/_snapshot/backup?pretty" -H 'Content-Type: application/json' -d'


"type": "fs",

"settings": {

"location": "/backup"

  "error" : {
    "root_cause" : [
        "type" : "exception",
        "reason" : "failed to create blob container"
    "type" : "exception",
    "reason" : "failed to create blob container",
    "caused_by" : {
      "type" : "access_denied_exception",
      "reason" : "/backup/tests-eyEtjaA0TymhJwuNPOh95g"
  "status" : 500

Many thanks.

Hi @ion_popa

It appears that the Elasticsearch process does not have the necessary permissions to write to the /backup path? Can you make make sure that the ES process's user+group has write permissions to /backup?

Hi @Armin - It's odd but when I initially gave it permissions elasticsearch:elasticsearch, it didn't work and threw the same error. It has eventually worked when I ran Puppet again and then re-added permissions to the backup folder for the elasticsearch. Thanks though :slight_smile: sorry for not updating this thread earlier.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.