Cannot get csv data to load into elasticsearch


(Deepak Paramanand) #1

Hi,

I have a CSV file that I want to index into Elasticsearch and I also want to see what has been written to elasticsearch, so I have created a conf file as below:

input {

file {
path => ["C:\Work\Kodiak\ATT\Data\RAR\test.txt"]
start_position => "beginning"
}
}

filter {
csv {
separator => ","
}
}

output {

elasticsearch {
index => "samples4"
}

file {
path => "C:\Work\Kodiak\ATT\Data\RAR\test.txt"
}

}

When I execute the logstash command, this is what shows up:

D:\Work\logstash-1.5.4\bin>logstash -f "D:\Work\logstash-1.5.4\rar.conf"
io/console not supported; tty will not be manipulated
Logstash startup completed

I have started elasticsearch-1.7.2. and the command

GET _cat/indices

does not show my index


(Magnus Bäck) #2

Almost exactly the same question was asked about five minutes ago:


(Deepak Paramanand) #3

I changed the windows settings to show the hidden files, but I cant seem to find the .sincedb file, could you please point me to it or mention where it usually hangs out?

Thank You,
Deepak


(Magnus Bäck) #4

According to the documentation the sincedb files are by default saved in the directory pointed to by the HOME environment variable (reading the code, it actually prefers SINCEDB_DIR but falls back to HOME if SINCEDB_DIR is unset).

If you crank up the loglevel by starting Logstash with --verbose it'll tell you the location of the sincedb file it's using.


(system) #5