Cannot get ElasticSearch Config to Create Custom Analyzers


(Wil Wade) #1

PasteBin of my attempted config: http://pastebin.com/175jeAMB

ElasticSearch 1.5.2

So I want to have a custom default analyzer, but after days of trying (and
almost every Google link turned purple), have failed to get it to work.

All I get back out is:
...

ElasticsearchIllegalArgumentException[failed to find analyzer type
[supplyhogText] or tokenizer for [default]]

...

for each index.

I have tried setting it up without the "index.analysis.analyzer.default.type
: "supplyhogText"" line, but it is like it doesn't see my definition lines.

Must be something really simple my tired eyes cannot see. Any ideas?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/14e8b5a1-e2e9-4914-b164-d585098bdaf9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jun Ohtani) #2

Hi Wil,

You should change supplyhogText to default in line 2, and delete last
line.

2015-04-28 4:51 GMT+09:00 Wil Wade willm.wade@gmail.com:

PasteBin of my attempted config: http://pastebin.com/175jeAMB

ElasticSearch 1.5.2

So I want to have a custom default analyzer, but after days of trying (and
almost every Google link turned purple), have failed to get it to work.

All I get back out is:
...

ElasticsearchIllegalArgumentException[failed to find analyzer type
[supplyhogText] or tokenizer for [default]]

...

for each index.

I have tried setting it up without the "
index.analysis.analyzer.default.type: "supplyhogText"" line, but it is
like it doesn't see my definition lines.

Must be something really simple my tired eyes cannot see. Any ideas?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/14e8b5a1-e2e9-4914-b164-d585098bdaf9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/14e8b5a1-e2e9-4914-b164-d585098bdaf9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--

Jun Ohtani
blog : http://blog.johtani.info

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAPW8A5zNDiTKLATpi%2B%2BMET2Lp4mOhMHbhORh97qPA4gtBg3jgQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3