Cannot install 2.1 from Debian repository


#1

I'm trying to install ElasticSearch 2.1 on Ubuntu 14 following these instructions https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-repositories.html.

I have followed the instructions exactly, but receive the error message "E: Unable to locate package elasticsearch."

Downloading 1.7 works fine (echo "deb http://packages.elastic.co/elasticsearch/1.7/debian stable main" | sudo tee -a /etc/apt/sources.list.d/elasticsearch-1.7.list). It is the 2.x version that is not working.


(Mark Walkom) #2

Worked perfectly fine for me?


#3

I have tried it on a newly installed virtually machine and receive the same error message.


(Mark Walkom) #4

https://gist.github.com/markwalkom/337ac5ff2567ef3b8b0a for my results


#5

Here are my results: http://pastebin.com/raw.php?i=631eqvtF

It looks like the difference is that I am on a 32-bit architecture and yours is 64-bit.


(Mark Walkom) #6

Oh, I don't know if we have 32 bit packages?


#7

Okay, thank you for the help, I'll install manually. Are there any plans to have 32-bit packages for the 2.x releases?


(Mark Walkom) #8

I've asked the team, will see what they say.


#9

Hi Mark, is there any update from the team?


(Aaron Mildenstein) #10

We don't build 32bit packages. I'm not even sure whether Elasticsearch will work properly with a 32bit JVM. I'd download the tarball and test it before going to the next step.


(Tin Le) #11

ES does work with 32bit JVM. At least up to v1.7.3.

$ java -version
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) Server VM (build 25.60-b23, mixed mode)
$ uname -a
Linux xxxxx 4.2.6-301.fc23.i686+PAE #1 SMP Fri Nov 20 22:42:36 UTC 2015 i686 i686 i386 GNU/Linux
$ rpm -qav|grep -i elastic
elasticsearch-1.7.3-1.noarch

Tin


(system) #12