Cannot search the field of the attachment type?


(Ivan Ji) #1

Dear all,

I cannot able to query the field of attachment type. I followed the
instruction
in http://es-cn.medcl.net/tutorials/2011/07/18/attachment-type-in-action.html.

And the result of the search query:

curl "http://localhost:9200/_search?pretty=true" -d '{
"fields" : ["title"],
"query" : {
"query_string" : {
"query" : "amplifier"
}
},
"highlight" : {
"fields" : {
"file" : {}
}
}
}'

result:

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

My ElasticSearch is the latest version, elasticsearch-0.90.9 and the plugin of mapper-attachment is 1.9.0 (https://github.com/elasticsearch/elasticsearch-mapper-attachments).

In fact, the environment finished the setup yesterday. I have no clue why it cannot find anything.

Any ideas?

Regards,

Ivan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0768325-af0d-4aeb-ae2d-499fac1ca08a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Hard to say. Not enough details about what you did.
Could you gist a curl recreation and also add in it the result of a _search?q=*&pretty

Did you restart elasticsearch after plugin installation?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2014 à 07:52, HongXuan Ji hxuanji@gmail.com a écrit :

Dear all,

I cannot able to query the field of attachment type. I followed the instruction in http://es-cn.medcl.net/tutorials/2011/07/18/attachment-type-in-action.html.

And the result of the search query:

curl "http://localhost:9200/_search?pretty=true" -d '{
"fields" : ["title"],
"query" : {
"query_string" : {
"query" : "amplifier"
}
},
"highlight" : {
"fields" : {
"file" : {}
}
}
}'

result:
{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

My ElasticSearch is the latest version, elasticsearch-0.90.9 and the plugin of mapper-attachment is 1.9.0 (https://github.com/elasticsearch/elasticsearch-mapper-attachments).
In fact, the environment finished the setup yesterday. I have no clue why it cannot find anything.

Any ideas?

Regards,

Ivan

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0768325-af0d-4aeb-ae2d-499fac1ca08a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/748BDAC4-08DA-4BCD-8764-A03E637758A6%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Ji) #3

Hi, David,

This is the result of _search?q=*&pretty:

{
"took": 0,
"timed_out": false,
"_shards": {
"total": 1,
"successful": 1,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "test",
"_type": "attachment",
"_id": "9wsReuxrSzCC0qrRHsYYPg",
"_score": 1,
"_source": {
"file":
"PGh0bWw+VGhpcyBwYWdlIG1vdmVkIHRvIDxhIGhyZWY9Ig0KL2NvbnRlbnQvZGFtL0ludGVyc2lsL2RvY3VtZW50cy9mbjY3L2ZuNjc0Mi5wZGYNCg==Ij5oZXJlPC9hPjwvaHRtbD4NCg=="
}
}
]
}
}

BTW, I did restart the ES after the plugin installed.

Ideas?

Thanks, a lot.

David Pilato於 2014年1月7日星期二UTC+8下午3時08分49秒寫道:

Hard to say. Not enough details about what you did.
Could you gist a curl recreation and also add in it the result of a
_search?q=*&pretty

Did you restart elasticsearch after plugin installation?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2014 à 07:52, HongXuan Ji <hxu...@gmail.com <javascript:>> a
écrit :

Dear all,

I cannot able to query the field of attachment type. I followed the
instruction in
http://es-cn.medcl.net/tutorials/2011/07/18/attachment-type-in-action.html
.

And the result of the search query:

curl "http://localhost:9200/_search?pretty=true" -d '{
"fields" : ["title"],
"query" : {
"query_string" : {
"query" : "amplifier"
}
},
"highlight" : {
"fields" : {
"file" : {}
}
}
}'

result:

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

My ElasticSearch is the latest version, elasticsearch-0.90.9 and the plugin of mapper-attachment is 1.9.0 (https://github.com/elasticsearch/elasticsearch-mapper-attachments).

In fact, the environment finished the setup yesterday. I have no clue why it cannot find anything.

Any ideas?

Regards,

Ivan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d0768325-af0d-4aeb-ae2d-499fac1ca08a%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fa4c12da-c9d4-427f-abc1-299692886046%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

I used http://www.base64decode.org/ to look at your indexed document.

Result is: "This page moved to <a href="
/content/dam/Intersil/documents/fn67/fn6742.pdf
#W&S FР"

I guess you now have the explanation! :slight_smile:

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 janvier 2014 at 09:16:03, HongXuan Ji (hxuanji@gmail.com) a écrit:

Hi, David,

This is the result of _search?q=*&pretty:

{
"took": 0,
"timed_out": false,
"_shards": {
"total": 1,
"successful": 1,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "test",
"_type": "attachment",
"_id": "9wsReuxrSzCC0qrRHsYYPg",
"_score": 1,
"_source": {
"file": "PGh0bWw+VGhpcyBwYWdlIG1vdmVkIHRvIDxhIGhyZWY9Ig0KL2NvbnRlbnQvZGFtL0ludGVyc2lsL2RvY3VtZW50cy9mbjY3L2ZuNjc0Mi5wZGYNCg==Ij5oZXJlPC9hPjwvaHRtbD4NCg=="
}
}
]
}
}

BTW, I did restart the ES after the plugin installed.

Ideas?

Thanks, a lot.

David Pilato於 2014年1月7日星期二UTC+8下午3時08分49秒寫道:
Hard to say. Not enough details about what you did.
Could you gist a curl recreation and also add in it the result of a _search?q=*&pretty

Did you restart elasticsearch after plugin installation?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2014 à 07:52, HongXuan Ji hxu...@gmail.com a écrit :

Dear all,

I cannot able to query the field of attachment type. I followed the instruction in http://es-cn.medcl.net/tutorials/2011/07/18/attachment-type-in-action.html.

And the result of the search query:

curl "http://localhost:9200/_search?pretty=true" -d '{
"fields" : ["title"],
"query" : {
"query_string" : {
"query" : "amplifier"
}
},
"highlight" : {
"fields" : {
"file" : {}
}
}
}'

result:
{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

My ElasticSearch is the latest version, elasticsearch-0.90.9 and the plugin of mapper-attachment is 1.9.0 (https://github.com/elasticsearch/elasticsearch-mapper-attachments).
In fact, the environment finished the setup yesterday. I have no clue why it cannot find anything.

Any ideas?

Regards,

Ivan

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0768325-af0d-4aeb-ae2d-499fac1ca08a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fa4c12da-c9d4-427f-abc1-299692886046%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52cbc22a.32fff902.11bb1%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Ji) #5

OH!
It's so embarrassed. Anyway, thanks for the tip.

Best,

Ivan

David Pilato於 2014年1月7日星期二UTC+8下午5時00分25秒寫道:

I used http://www.base64decode.org/ to look at your indexed document.

Result is: "This page moved to <a href="
/content/dam/Intersil/documents/fn67/fn6742.pdf

  • #W&S FР*"

I guess you now have the explanation! :slight_smile:

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 7 janvier 2014 at 09:16:03, HongXuan Ji (hxu...@gmail.com <javascript:>)
a écrit:

Hi, David,

This is the result of _search?q=*&pretty:

{
"took": 0,
"timed_out": false,
"_shards": {
"total": 1,
"successful": 1,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "test",
"_type": "attachment",
"_id": "9wsReuxrSzCC0qrRHsYYPg",
"_score": 1,
"_source": {
"file":
"PGh0bWw+VGhpcyBwYWdlIG1vdmVkIHRvIDxhIGhyZWY9Ig0KL2NvbnRlbnQvZGFtL0ludGVyc2lsL2RvY3VtZW50cy9mbjY3L2ZuNjc0Mi5wZGYNCg==Ij5oZXJlPC9hPjwvaHRtbD4NCg=="
}
}
]
}
}

BTW, I did restart the ES after the plugin installed.

Ideas?

Thanks, a lot.

David Pilato於 2014年1月7日星期二UTC+8下午3時08分49秒寫道:

Hard to say. Not enough details about what you did.
Could you gist a curl recreation and also add in it the result of a
_search?q=*&pretty

Did you restart elasticsearch after plugin installation?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2014 à 07:52, HongXuan Ji hxu...@gmail.com a écrit :

Dear all,

I cannot able to query the field of attachment type. I followed the
instruction in
http://es-cn.medcl.net/tutorials/2011/07/18/attachment-type-in-action.html
.

And the result of the search query:

curl "http://localhost:9200/_search?pretty=true" -d '{
"fields" : ["title"],
"query" : {
"query_string" : {
"query" : "amplifier"
}
},
"highlight" : {
"fields" : {
"file" : {}
}
}
}'

result:

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

My ElasticSearch is the latest version, elasticsearch-0.90.9 and the plugin of mapper-attachment is 1.9.0 (https://github.com/elasticsearch/elasticsearch-mapper-attachments).

In fact, the environment finished the setup yesterday. I have no clue why it cannot find anything.

Any ideas?

Regards,

Ivan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d0768325-af0d-4aeb-ae2d-499fac1ca08a%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/fa4c12da-c9d4-427f-abc1-299692886046%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d8b21d4f-393e-4267-8fd3-40617c40b708%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6