Cannot sort on nested, multi_field, not_analyzed field


(kwisarts) #1

Good day,

I've been trying for a while to sort on a nested, multi_field, not_analyzed
field of documents in our index.

Here's the relevant part of my mapping. Please focus on the name.na field

"booth": {

    "properties": {
        "details" : {
            "type": "nested",
            "properties": {
                "locale" : {
                    "type": "string",
                    "index": "not_analyzed"
                },
                "name": {
                    "type": "multi_field",
                    "fields": {
                        "na": {
                            "type": "string",
                            "index": "not_analyzed"
                        },
                        "standard": {
                            "type": "string",
                            "analyzer": "full_name"
                        },
                        "ngrams": {
                            "search_analyzer": "full_name",
                            "index_analyzer": "ngrammed",
                            "type": "string"
                        },
                        "keyword": {
                            "type": "string",
                            "analyzer": "asis"
                        }
                    }
                },
                "description": {
                    "type": "string",
                    "analyzer": "full_name"
                }
            }
        },

Both name and description fields contain simple text only.
For illustration purposes, let's consider I was running just the sort:

{

"sort": [
{
"details.name.na": {
"order": "desc"
}
}
]
}

Sorting on that field doesn't work, which is made pretty clear by
elasticsearch's response:

  • sort: [

  • null

  • ]

Now, sorting on the details.description field does work (but that's not
what I want).

Any ideas what I'm doing wrong here?

Thanks,
David

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2