Cannot telnet the dedicated master nodes on port 9200 after configuration


(Sara Thomas) #1

Hi,

I want an architecture with three dedicated master node and 4 dedicated data node with one Load balance node (all in one cluster). For this I configured the the first dedicated master node

node.data: false

When I did the same configuration for the next master node I am not able to telnet the node on port 9200 (I get a Connection refused error).

How can I create 3 dedicated master node in elasticsearch within cluster along with 4 dedicated data nodes?

I had even set the discovery.zen.minimum_master_nodes: 2
Still I am facing this issue?


(Magnus B├Ąck) #2

With the default configuration ES only listens on the loopback interface. Make sure you have adjusted the network.host setting.

https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-network.html


(Nik Everett) #3

Hard to tell from here, but maybe it is a binding problem? By default
elasticsearch binds to local host only. I'd you configure it to bind to a
non-local address then it'll just bind to that address. You can configure
it to bind to both the non-local address and local host by listing both as
a yaml array.

You may also want to check with lsof.


(Sara Thomas) #4

Hi,

I have bind the local address.

network.host: x.x.x.x # IP of the particular node. It's private IP
discovery.zen.ping.unicast.hosts: [all the master nodes and data nodes]


(Nik Everett) #5

Then it should work fine. Just make sure to telnet to x.x.x.x instead of localhost. If you can't do it from the other machine then I expect a networking issue. You can use lsof to figure out if Elasticsearch has bound to the right port on that address.


(Sara Thomas) #6

Hi Nik,

I tried lsof . I could see the established connection between the data and master nodes only when I don't specify

node.data: false

in the configuration.


(system) #7