Cannot update cluster settings


#1

Hi all,

I've upgraded my cluster from 5.6 to 6.2.2 and using x-pack tls only. After upgrade cluster status is yellow and i am trying to enable routing shard allocation.

PUT _cluster/settings
{
  "transient": {
    "cluster.routing.allocation.enable": "all"
  }
}

but recieving the following error which is not related to paremeter i am trying to change.

{
"error": {
"root_cause": [
{
"type": "remote_transport_exception",
"reason": "[KLLLKELK02][10.80.43.6:9300][cluster:admin/settings/update]"
}
],
"type": "illegal_argument_exception",
"reason": "unknown setting [archived.cluster.routing.allocation.disk.watermark.low] did you mean any of [cluster.routing.allocation.disk.watermark.low, cluster.routing.allocation.disk.watermark.high]?"
},
"status": 400
}

I have added

xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.key: /etc/elasticsearch/x-pack/certs/${node.name}.key
xpack.security.transport.ssl.certificate: /etc/elasticsearch/x-pack/certs/${node.name}.crt
xpack.security.transport.ssl.certificate_authorities: [ "/etc/elasticsearch/x-pack/certs/ca.crt" ]

to my elasticsearch yml and GET _cluster/health GET _cat/allocation works well.

any ideas?


#2

Solved...

I dont know how but "archived" was added to cluster setting, after setting archived.cluster.routing.allocation.disk.watermark.low : null i could send new settings. But still wondering how it happened.


(Alexander Reelsen) #3

you may have hit this one


#4

Exactly. Thank you for informing me...


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.