I have this command as part of my process to build a docker image for Logstash. It worked fine a month ago, and today it is failing.
logstash-plugin update logstash-filter-grok
Here's the exact error message:
An error occurred while installing ffi (1.13.1), and Bundler cannot continue. Make sure that `gem install ffi -v '1.13.1'` succeeds before bundling.
And if I try to install ffi directly, I get this error
ERROR: Error installing ffi: ffi requires Ruby version >= 2.3.
But installing ffi 1.12.2 works fine.
Fetching: ffi-1.12.2-java.gem (100%) Successfully installed ffi-1.12.2-java
Why now? Seems to be because ffi 1.13.0 was released to RubyGems on June 1st, and this new version now requires a new version of Ruby.
How can I get logstash-plugin to update the filter-grok plugin but NOT attempt to install the latest version of
ffi? I already tried pre-installing firstname.lastname@example.org but still ended up with the same error from
Additional info: my docker image build is based on FROM logstash:5.6.6.