Can't able to create index in ES via filebeat


(Prem Kumar) #1

I am new to ELK and I am trying to load logs from Filebeats to ES but index are not getting created. I have looked into lot of threads in this forum regarding this but I can't able to find a solution.
I can able to load the data by using logstash but I want to implement it by Filebeats.
I am trying Filebeats -> ES
I have attached my configuration and logs. Any idea on what I am doing wrong?

filebeat.prospectors:

- type: log

  enabled: true

  paths:
    #- /var/log/*.log
    - C:\logfiles\logs\*\*.*

filebeat.config.modules:
  path: ${path.config}/modules.d/*.yml

  reload.enabled: true

setup.template.settings:
  index.number_of_shards: 3

setup.kibana:

output.elasticsearch:
  hosts: ["localhost:9200"]

Note : In file path, I have even tried by giving absolute file path.


(Pier-Hugues Pellerin) #2

Hello @prem_kumar,

I do not see errors in the logs, but I think Filebeat is not finding any files. This is confirmed by looking at the metric log statement.

I haven't tested it but I believe you have to use forward slashes.

C:/LogFiles/logs/*/*.*

Thanks


(Prem Kumar) #3

hi @pierhugues
Thanks for the update :slight_smile: . adding the file path inside a single quote solved my issue.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.