Can't change logging level for TransportClient under JBoss


(Adam) #1

We get INFO level messages for org.elasticsearch to the jboss server.log. But when I try to change the level to DEBUG, via jboss-logging.xml

<logger category="org.elasticsearch">
    <level name="DEBUG" />
</logger>

we still only get INFO level messages (other category DEBUG show up in the log).
Please help this is extremely frustrating trying to trouble shoot connectivity issues for the TransportClient!


(Jörg Prante) #2

You can't set Elasticsearch logging from jboss-logging.xml

Elasticsearch uses log4j and is using an internal log4j configurator.

Unfortunately, the TransportClient is missing log configuration.

To configure logging for the TransportClient, try the following steps:

  • copy your custom log4j configuration settings into a file logging.yml
    (optionally logging.json or logging.properties)

  • take the Settings object from the TransportClient initialization, and add
    a path.conf setting to the directory where you have placed the file from
    the previous step

  • after TransportClient initialization, add a line
    LogConfigurator.configure(settings); in your code. The LogConfigurator is
    in the package org.elasticsearch.common.logging.log4j

Do not forget to add log4j (optionally slf4j-log4j) to your classpath.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3