Can't connect to http-input of Logstash on Elastic Cloud

Hi, i just deployed an elastic cloud instance on google cloud. I want to use the http input plugin of Logstash to receive sensor data (from "the things network") via webhook requests. I configured the Logstash pipeline on the elastic cloud as follows:

input {
  http {
    host => "0.0.0.0"
    port => "8080"
  }
}
filter {
}
output {
  elasticsearch {
    index => "mytestindex"
  }
}

I would like to use the port 8080 for the incoming requests. However, I cannot connect to this port on the elastic cloud as it is probably closed. How can I enable this? And is my intended solution a good one for receiving data from a webhook?

Thanks! Samuel

Welcome to our community! :smiley:

Elastic Cloud doesn't provide hosted Logstash, you need to have this hosted externally.

Dear Mark

Thanks for you reply. I thought so too before I deployed. But then, to my suprise, I found it integrated in elastic cloud:

So know I'm wondering how to configure the ports für the http input.

That's the UI for Centralized Pipeline Management | Logstash Reference [7.14] | Elastic.

Mark, thanks, my understanding now is that I need to run logstash somewhere else and then connect to elastic cloud which would allow me to configure my logstash with the elastic cloud UI. Right?

That is correct.