Cant get apache module working


(Pavan Kumar) #1

Hi,

I installed filebeat on client server. And used the following guide to start filebeat with apache2 module: https://www.elastic.co/guide/en/beats/filebeat/5.3/filebeat-modules-quickstart.html
I used the default settings for .json files filebeat.template-es2x.json and filebeat.template.json.

I updated my filebeat.yml to the following:

#========================== Modules configuration ============================
filebeat.modules:

#------------------------------- Apache2 Module ------------------------------

  • module: apache2

    Access logs

    access:
    enabled: true
    var.paths: ["/var/log/apache2/access.log"]
    error:
    enabled: true
    var.paths: ["/var/log/apache2/error.log"]

    Set custom paths for the log files. If left empty,

    Filebeat will choose the paths depending on your OS.

var.paths: ["/var/logs/httpd"]

I am using the following command to start my filebeat:
nohup /usr/share/filebeat/bin/filebeat -e -modules=apache2 -setup &

Filebeat starts fine but I cant see any apache information in my Kibana. The article suggests it would show up in Kibana. I am not seeing any errors in my logs. Can anyone please help? Thanks.


(Christian Dahlqvist) #2

Filebeat modules use an ingest pipeline to parse the data, so Elasticsearch 5.x or higher will be required.


(Pavan Kumar) #3

got it thank you.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.