Cant get to elastic when localhost replaced with server name


(william crawley) #1

HI All,

I have elastic search 5.5.1 installed with xpack. I've created an index and used fscrawler to populate it. Via Postman, I perform a GET on a url in the form localhost:9200/myindex/_search?q="William" and it all works fine. If I change localhost to the ip 127.0.0.1 it still works. If I change it to the servername then postman comes back with could not get any response. All of this from the same server that everything has been installed on.

I need to get it to work using the server name since I obviously want to make the call from other machines. What do I need to do to make it recognize the server name?


(Colin Goodheart-Smithe) #2

By default the server will only bind to localhost addresses. If you want to bind to an external interface you will need to set either http.host or http.bind_host to your external interfaces IP address. See the following for more information on these settings: https://www.elastic.co/guide/en/elasticsearch/reference/5.5/modules-http.html#_settings_2


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.