Can't install Elastic Agent on MacOS Ventura (13.3.1) - Symlink

Hey guys,

I can't install elastic agent on my new MacBook running MacOS Ventura 13.3.1. Installing I get the following message:

martin@Martins-MacBook-Pro-14 elastic-agent-8.7.0-darwin-aarch64 % sudo ./elastic-agent install --url= --enrollment-token=VE...XX== --insecure
Elastic Agent will be installed at /Library/Elastic/Agent and will run as a service. Do you want to continue? [Y/n]:Y

Error: failed to create elastic-agent symlink (/usr/local/bin/elastic-agent): symlink /Library/Elastic/Agent/elastic-agent /usr/local/bin/elastic-agent: no such file or directory
For help, please see our troubleshooting guide at

And yes the Terminal Application has full disk access:

I am running ELK stack on version 8.5.2 (Standalone).
I tried installing elastic-agent-8.5.2-darwin-aarch64 and also elastic-agent-8.7.0-darwin-aarch64 (newest, see above) with the same result.

Can anybody help me?


Did you try to install a previous version?

Ahh I see you did...

Perhaps you are half-installed...

Was it the same error with 8.5.2?

Yes exactly the same :frowning:

So I would try to uninstall it first...

/Library/Elastic/Agent/elastic-agent uninstall

Unfortunately, this is one of the few things I can not test on my mac... as I work for Elastic and the Agent is installed already on my Mac as a managed Asset (we run it as AV / AM etc)

And this is an M1/2 Mac?

Ok done. What now?

Its a M2 Pro MacBook

try to re-install

I had someone before that needed to try to install / uninstall each of the versions he tried... once it got contaminated...

We have 1000s of agents installed on Macs ... so it does work I know that does not help you a lot.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.