Can't install elasticsearch in Ubuntu 16.04


(Altiano Gerung) #1

I can't install elastic search via the package manager or manually download it.

I got this error when installing:
Preparing to unpack elasticsearch-6.5.1.deb ...
dpkg: error processing archive elasticsearch-6.5.1.deb (--install):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
elasticsearch-6.5.1.deb


(Mark Walkom) #2

Do you have java installed?


(Altiano Gerung) #3

Oh you're right..
I thought that it will install java automatically
Not what I was expecting..
Thanks.